aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lua-mimetypes
diff options
context:
space:
mode:
authorGuilherme Felipe da Silva <gfsilva.eng@gmail.com>2020-03-04 14:03:46 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-03-09 16:04:48 -0300
commitfeb1e64c95784c0aa901fcf506564323291c4ba7 (patch)
tree576124ca46ef06abd0e9214d594c16e65c0accf6 /testing/lua-mimetypes
parent97021acf8e60d4a0cfe044b7403dcfaef8fa7d78 (diff)
downloadaports-feb1e64c95784c0aa901fcf506564323291c4ba7.tar.bz2
aports-feb1e64c95784c0aa901fcf506564323291c4ba7.tar.xz
testing/lua-mimetypes: prevent manifest overwrite
The luarocks manifest file is managed by luarocks itself, remove it from build to prevent overwrite
Diffstat (limited to 'testing/lua-mimetypes')
-rw-r--r--testing/lua-mimetypes/APKBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/testing/lua-mimetypes/APKBUILD b/testing/lua-mimetypes/APKBUILD
index 978ec953af..768212c800 100644
--- a/testing/lua-mimetypes/APKBUILD
+++ b/testing/lua-mimetypes/APKBUILD
@@ -2,7 +2,7 @@
pkgname=lua-mimetypes
_rockname="${pkgname#lua-}"
pkgver=1.0.0
-pkgrel=0
+pkgrel=1
pkgdesc="A MIME type database for Lua. You can use this in servers and the like to check the MIME types of files"
url="https://bitbucket.org/leafstorm/lua-mimetypes"
license="MIT"
@@ -30,6 +30,8 @@ build() {
LUA_LIBDIR="$(pkg-config --variable=libdir lua$lver)" \
make --tree="./build" \
"rockspecs/$_rockname-$pkgver-1.rockspec"
+
+ rm "./build/lib/luarocks/rocks-$lver/manifest"
done
}