aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lua-rex
diff options
context:
space:
mode:
authorAndrew Manison <amanison@anselsystems.com>2010-07-27 15:27:42 +0000
committerAndrew Manison <amanison@anselsystems.com>2010-07-27 15:27:42 +0000
commitd135d0bcf985282f2b600f7c8a5fabadb5d454a6 (patch)
tree2100539f79ce4f1aea70600a96b9e8529dc4c18e /testing/lua-rex
parentced0fad7eddb52a4c80c58cf610fcbd7defd3e9f (diff)
downloadaports-d135d0bcf985282f2b600f7c8a5fabadb5d454a6.tar.bz2
aports-d135d0bcf985282f2b600f7c8a5fabadb5d454a6.tar.xz
testing/lua-rex: renamed directory to match package name, from lua-rexlib to lua-rex.
Diffstat (limited to 'testing/lua-rex')
-rw-r--r--testing/lua-rex/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/testing/lua-rex/APKBUILD b/testing/lua-rex/APKBUILD
new file mode 100644
index 0000000000..4f7bce0891
--- /dev/null
+++ b/testing/lua-rex/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor:
+# Maintainer:
+pkgname=lua-rex
+pkgver=2.4.0
+pkgrel=1
+pkgdesc="Lua bindings to regular expression library pcre and posix"
+url="http://lrexlib.luaforge.net/"
+license="MIT"
+depends="lua-rex-pcre lua-rex-posix"
+makedepends="pcre-dev lua-dev"
+install=
+subpackages="$pkgname-pcre $pkgname-posix"
+source="http://luaforge.net/frs/download.php/3599/lrexlib-$pkgver.zip"
+
+_builddir="$srcdir"/lrexlib-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ sed -i -e "s/^MYCFLAGS.*/MYCFLAGS = $CFLAGS/" src/defaults.mak
+ sed -i -e "s/^LD .*/LD = gcc/" \
+ src/common.mak
+}
+
+build() {
+ cd "$_builddir"
+ make -j1 build_pcre build_posix
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+pcre() {
+ pkgdesc="Lua bindings to pcre regular expressions library"
+ cd "$_builddir"
+ install -d "$subpkgdir"/usr/lib/lua/5.1
+ cp -a src/pcre/rex_pcre.so* "$subpkgdir"/usr/lib/lua/5.1
+}
+
+posix() {
+ pkgdesc="Lua bindings to posix regular expressions library"
+ cd "$_builddir"
+ install -d "$subpkgdir"/usr/lib/lua/5.1
+ cp -a src/posix/rex_posix.so* "$subpkgdir"/usr/lib/lua/5.1
+}
+
+md5sums="c75d4164ac5036219eac87b488ded9b7 lrexlib-2.4.0.zip"