aboutsummaryrefslogtreecommitdiffstats
path: root/testing/luakit/APKBUILD
diff options
context:
space:
mode:
authorAlex Raschi <raschi.alex@gmail.com>2019-02-05 15:20:45 +0100
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-03-05 10:43:58 +0000
commit4fd1f514dbbb775adf114483a40f4781781c5a9d (patch)
tree82019b53532042f01e3d4e32d1ad5ad6dcdef11b /testing/luakit/APKBUILD
parent7adc1ff7536858bdd21aaf8062b3433bf07eb8df (diff)
downloadaports-4fd1f514dbbb775adf114483a40f4781781c5a9d.tar.bz2
aports-4fd1f514dbbb775adf114483a40f4781781c5a9d.tar.xz
testing/luakit: enable tests
* move a dir in -doc subpackage too
Diffstat (limited to 'testing/luakit/APKBUILD')
-rw-r--r--testing/luakit/APKBUILD25
1 files changed, 17 insertions, 8 deletions
diff --git a/testing/luakit/APKBUILD b/testing/luakit/APKBUILD
index d0cbf548d0..825814b4c4 100644
--- a/testing/luakit/APKBUILD
+++ b/testing/luakit/APKBUILD
@@ -2,18 +2,18 @@
# Maintainer:
pkgname=luakit
pkgver=2.1
-pkgrel=0
+pkgrel=1
pkgdesc="Fast, small, webkit based browser framework extensible by Lua"
-url="https://github.com/luakit/luakit"
+url="https://luakit.github.io/"
arch="all !s390x" # luajit is missing for s390x
-license="GPL-3.0"
-depends="lua5.1-filesystem lua5.1-luassert"
-depends_dev=""
+license="GPL-3.0-or-later"
+depends="gsettings-desktop-schemas lua5.1-filesystem"
makedepends="webkit2gtk-dev luajit-dev"
-install=""
+checkdepends="xvfb luacheck lua5.1-luassert"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/$pkgname/$pkgname/archive/$pkgver.tar.gz
- config-mk.patch"
+ config-mk.patch
+ tests.patch"
builddir="$srcdir/$pkgname-$pkgver"
build() {
@@ -21,10 +21,19 @@ build() {
make PREFIX=/usr USE_LUAJIT=1 DEVELOPMENT_PATHS=0
}
+check() {
+ cd "$builddir"
+ make run-tests
+}
+
package() {
cd "$builddir"
make PREFIX=/usr DESTDIR="$pkgdir" install
+ mkdir -p "$pkgdir"/usr/share/doc/"$pkgname"
+ mv "$pkgdir"/usr/share/"$pkgname"/doc/* "$pkgdir"/usr/share/doc/"$pkgname"
+ rmdir "$pkgdir"/usr/share/"$pkgname"/doc
}
sha512sums="1daee7fe4bf5fad0f2c70d714c316914c601467facafdb22e4f27c18a691e249cefd5680ede834bcc555041afdc5d7e70610e2cd5e33db1ad8d9f2fe0327ccac luakit-2.1.tar.gz
-d852a17bf202b18e75bda3885e421a957ce501ebbeb0ecd6e7a6379747e350878c9f95683a0385ce9daa719ddd02a3e5d5143ebd9ee892a469d8457e7a863b5a config-mk.patch"
+d852a17bf202b18e75bda3885e421a957ce501ebbeb0ecd6e7a6379747e350878c9f95683a0385ce9daa719ddd02a3e5d5143ebd9ee892a469d8457e7a863b5a config-mk.patch
+6d0b3a93b7bedcdd3ebe7283d734d013aa25683a9effc841f4a57aa8f2ea34dc68dc4bd35a22436d28e4011c60243047b72ff8d81affb349912de43e1e20232f tests.patch"