aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lxd/lxd-dont-go-get.patch
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-09-08 13:21:31 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-09-08 13:21:40 +0000
commit28004e62cb14c545e7866dd5ac9b020ba28c64e4 (patch)
treee21c52bb534d2aa38c7e4c720e0cedd42cbb050f /testing/lxd/lxd-dont-go-get.patch
parentc3db9cef255232c447e66f8c63c4fa138d6cf024 (diff)
downloadaports-28004e62cb14c545e7866dd5ac9b020ba28c64e4.tar.bz2
aports-28004e62cb14c545e7866dd5ac9b020ba28c64e4.tar.xz
testing/lxd: upgrade to 2.17
Diffstat (limited to 'testing/lxd/lxd-dont-go-get.patch')
-rw-r--r--testing/lxd/lxd-dont-go-get.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/testing/lxd/lxd-dont-go-get.patch b/testing/lxd/lxd-dont-go-get.patch
new file mode 100644
index 0000000000..506e56b956
--- /dev/null
+++ b/testing/lxd/lxd-dont-go-get.patch
@@ -0,0 +1,18 @@
+diff --git a/Makefile b/Makefile
+index 3a0cc01..1d54c9d 100644
+--- a/Makefile
++++ b/Makefile
+@@ -13,13 +13,11 @@ TAGS=$(shell test -e /usr/include/sqlite3.h && echo "-tags libsqlite3")
+
+ .PHONY: default
+ default:
+- go get -t -v -d ./...
+ go install -v $(TAGS) $(DEBUG) ./...
+ @echo "LXD built successfully"
+
+ .PHONY: client
+ client:
+- go get -t -v -d ./...
+ go install -v $(TAGS) $(DEBUG) ./lxc
+ @echo "LXD client built successfully"
+