aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lxd/lxd-dont-go-get.patch
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2018-12-18 14:31:08 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2018-12-18 14:34:14 +0000
commitc335dd36c1f7120c293c7c1be19f06891939bf77 (patch)
treed8407b246f7003e573802a0e5937f27a3f784726 /testing/lxd/lxd-dont-go-get.patch
parente7821190c46e6959ae256e050167d456d71c0591 (diff)
downloadaports-c335dd36c1f7120c293c7c1be19f06891939bf77.tar.bz2
aports-c335dd36c1f7120c293c7c1be19f06891939bf77.tar.xz
testing/lxd: upgrade to 3.8
Diffstat (limited to 'testing/lxd/lxd-dont-go-get.patch')
-rw-r--r--testing/lxd/lxd-dont-go-get.patch52
1 files changed, 46 insertions, 6 deletions
diff --git a/testing/lxd/lxd-dont-go-get.patch b/testing/lxd/lxd-dont-go-get.patch
index 506e56b956..22593ef5ed 100644
--- a/testing/lxd/lxd-dont-go-get.patch
+++ b/testing/lxd/lxd-dont-go-get.patch
@@ -1,18 +1,58 @@
diff --git a/Makefile b/Makefile
-index 3a0cc01..1d54c9d 100644
+index 99f2aa6..4d79b8b 100644
--- a/Makefile
+++ b/Makefile
-@@ -13,13 +13,11 @@ TAGS=$(shell test -e /usr/include/sqlite3.h && echo "-tags libsqlite3")
+@@ -15,13 +15,11 @@ ifeq ($(TAG_SQLITE3),)
+ exit 1
+ endif
- .PHONY: default
- default:
- go get -t -v -d ./...
- go install -v $(TAGS) $(DEBUG) ./...
+ CC=$(CC) go install -v -tags "$(TAG_SQLITE3)" $(DEBUG) ./...
@echo "LXD built successfully"
.PHONY: client
client:
- go get -t -v -d ./...
- go install -v $(TAGS) $(DEBUG) ./lxc
+ go install -v -tags "$(TAG_SQLITE3)" $(DEBUG) ./lxc
@echo "LXD client built successfully"
+@@ -68,7 +66,6 @@ deps:
+
+ .PHONY: update
+ update:
+- go get -t -v -d -u ./...
+ @echo "Dependencies updated"
+
+ .PHONY: update-protobuf
+@@ -89,15 +86,11 @@ ifeq ($(TAG_SQLITE3),)
+ exit 1
+ endif
+
+- go get -t -v -d ./...
+ CC=$(CC) go install -v -tags "$(TAG_SQLITE3) logdebug" $(DEBUG) ./...
+ @echo "LXD built successfully"
+
+ .PHONY: check
+ check: default
+- go get -v -x github.com/rogpeppe/godeps
+- go get -v -x github.com/remyoudompheng/go-misc/deadcode
+- go get -v -x github.com/golang/lint/golint
+ go test -v -tags "$(TAG_SQLITE3)" $(DEBUG) ./...
+ cd test && ./main.sh
+
+@@ -113,7 +106,6 @@ dist:
+ ln -s ../../../../lxd-$(VERSION) $(TMP)/dist/src/github.com/lxc/lxd
+
+ # Download dependencies
+- cd $(TMP)/lxd-$(VERSION) && GOPATH=$(TMP)/dist go get -t -v -d ./...
+
+ # Download the cluster-enabled sqlite/dqlite
+ git clone --depth=1 https://github.com/CanonicalLtd/dqlite $(TMP)/dist/dqlite
+@@ -149,7 +141,6 @@ update-po:
+ done
+
+ update-pot:
+- go get -v -x github.com/snapcore/snapd/i18n/xgettext-go/
+ xgettext-go -o po/$(DOMAIN).pot --add-comments-tag=TRANSLATORS: --sort-output --package-name=$(DOMAIN) --msgid-bugs-address=lxc-devel@lists.linuxcontainers.org --keyword=i18n.G --keyword-plural=i18n.NG lxc/*.go lxc/*/*.go
+
+ build-mo: $(MOFILES)