aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lxd
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2019-09-09 10:20:33 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2019-09-09 10:20:33 +0000
commitb4f25fe2ab4797860d2ccddfb3ca2f461cb2d343 (patch)
treefca6356604ecc9dba7df69389458023328a8455d /testing/lxd
parentceaa607e8ed81d2605a28a186c1442b37eefa8a5 (diff)
downloadaports-b4f25fe2ab4797860d2ccddfb3ca2f461cb2d343.tar.bz2
aports-b4f25fe2ab4797860d2ccddfb3ca2f461cb2d343.tar.xz
testing/lxd: upgrade to 3.17:
Diffstat (limited to 'testing/lxd')
-rw-r--r--testing/lxd/APKBUILD10
-rw-r--r--testing/lxd/add-missing-includes.patch14
2 files changed, 20 insertions, 4 deletions
diff --git a/testing/lxd/APKBUILD b/testing/lxd/APKBUILD
index 0fef740d72..bc64e9eb78 100644
--- a/testing/lxd/APKBUILD
+++ b/testing/lxd/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=lxd
-pkgver=3.16
+pkgver=3.17
pkgrel=0
pkgdesc="a container hypervisor and a new user experience for LXC"
url="https://linuxcontainers.org/lxd/"
@@ -51,6 +51,7 @@ source="https://linuxcontainers.org/downloads/$pkgname/$pkgname-$pkgver.tar.gz
$pkgname.confd
$pkgname.initd
lxd-dont-go-get.patch
+ add-missing-includes.patch
"
# avoid conflict with system libsqlite3.so.0 by adding a soname prefix.
# this makes lxd-libs provide so:lxd:libsqlite3.so.0 and lxd depend on
@@ -63,7 +64,7 @@ _project="github.com/lxc/lxd"
prepare() {
export GOPATH="$builddir/_dist"
default_prepare
- update_config_guess
+ #update_config_guess
for p in raft sqlite dqlite; do
cd "$GOPATH"/deps/$p
autoreconf -i
@@ -166,7 +167,8 @@ libs() {
rm -r "$pkgdir"/etc
}
-sha512sums="11c6c5c49ceb23c31979829937e1baad340b8920481ef5b89b2b6d0b6b05967ec1f446f8b0330c11008f6fecea077eed0858af7fe802c50b52148757584fdfb9 lxd-3.16.tar.gz
+sha512sums="5dcfb423d091733736fb7df7ed14a638ecab1280863836d91e63823683521d4f4e1ee52f364cb76b0abf8382dc115598d96037c90d772a0b664476cb6917e7d7 lxd-3.17.tar.gz
bc32c71f2ce10f508433e1e4651c08c18e8a17e9419a7ce391c0f127fc7cf378c665178926b35eae8813e290d9c5eab3ceb605679fd32efdf2cf98a57cee4127 lxd.confd
94de0c0d5ab63463a929a4151359950b1117d0ada5ccf0944311cc70c6b6d4c437ccb4158734ab35db67bfb4abc437074c3f3515be4531f63adc74da21fefb5b lxd.initd
-7453a02f003b2b3ccc2695649ca6b39157f1bd30070815e6addaacb280ea935d79bc5d265925aeec379a16f0235387d8333c3f25519c959b980fe15ad2d5728c lxd-dont-go-get.patch"
+7453a02f003b2b3ccc2695649ca6b39157f1bd30070815e6addaacb280ea935d79bc5d265925aeec379a16f0235387d8333c3f25519c959b980fe15ad2d5728c lxd-dont-go-get.patch
+c9291e7df7e7d62324d6f31460268b138eaeb7928b2aceb9e1763bc123c4410557a887847e441c03efb92642a6c39c8db6557e2af6a738ac46a9df93b5ac1d3b add-missing-includes.patch"
diff --git a/testing/lxd/add-missing-includes.patch b/testing/lxd/add-missing-includes.patch
new file mode 100644
index 0000000000..fce3c9621c
--- /dev/null
+++ b/testing/lxd/add-missing-includes.patch
@@ -0,0 +1,14 @@
+diff --git a/_dist/deps/dqlite/src/vfs.c b/_dist/deps/dqlite/src/vfs.c
+index 31e138c..c5f9e9c 100644
+--- a/_dist/deps/dqlite/src/vfs.c
++++ b/_dist/deps/dqlite/src/vfs.c
+@@ -2,6 +2,9 @@
+ #include <sys/time.h>
+ #include <errno.h>
+
++#include <pthread.h>
++#include <sys/types.h>
++
+ #include <raft.h>
+
+ #include <sqlite3.h>