aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lxd
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-01-12 12:25:35 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-01-12 12:25:35 +0000
commitf89e1def8cc32f8e631bd4b7c9adc9918ed9ef4c (patch)
tree4c562705a9ddb08e447c055982957f5613a65fec /testing/lxd
parent5d4c75bf66caa9a38dcaf4cad256b61915b4967d (diff)
downloadaports-f89e1def8cc32f8e631bd4b7c9adc9918ed9ef4c.tar.bz2
aports-f89e1def8cc32f8e631bd4b7c9adc9918ed9ef4c.tar.xz
testing/lxd: fix dependencies of libsqlite3.so
we add soname prefix to avoid collision with syste libsqlite3.
Diffstat (limited to 'testing/lxd')
-rw-r--r--testing/lxd/APKBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/testing/lxd/APKBUILD b/testing/lxd/APKBUILD
index 5820fe9ebe..de2065b8ed 100644
--- a/testing/lxd/APKBUILD
+++ b/testing/lxd/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=lxd
pkgver=3.9
-pkgrel=1
+pkgrel=2
pkgdesc="a container hypervisor and a new user experience for LXC"
url="https://linuxcontainers.org/lxd/"
arch="all"
@@ -53,6 +53,12 @@ source="https://linuxcontainers.org/downloads/$pkgname/$pkgname-$pkgver.tar.gz
lxd-dont-go-get.patch
"
+# avoid conflict with system libsqlite3.so.0 by adding a soname prefix.
+# this makes lxd-libs provide so:lxd:libsqlite3.so.0 and lxd depend on
+# so:lxd:libsqlite3.so.0.
+ldpath="/usr/lib/lxd"
+sonameprefix="$pkgname:"
+
_project="github.com/lxc/lxd"
builddir="$srcdir"/lxd-$pkgver
@@ -74,14 +80,14 @@ build() {
--disable-amalgamation \
--disable-tcl \
--libdir=/usr/lib/lxd
-
+
cd "$GOPATH"/dqlite
PKG_CONFIG_PATH="${GOPATH}/sqlite/" ./configure \
--prefix=/usr \
--libdir=/usr/lib/lxd
-
+
cd "$GOPATH"/sqlite
- make
+ make
cd "$GOPATH"/dqlite
make CFLAGS="-I${GOPATH}/sqlite" LDFLAGS="-L${GOPATH}/sqlite"
@@ -102,7 +108,7 @@ package() {
export CGO_LDFLAGS="$CGO_LDFLAGS -lintl"
cd "$GOPATH"/sqlite
make DESTDIR="$pkgdir" install
-
+
cd "$GOPATH"/dqlite
make DESTDIR="$pkgdir" install
@@ -112,7 +118,7 @@ package() {
cd $GOPATH
install -Dm755 bin/$pkgname "$pkgdir"/usr/sbin/$pkgname
install -Dm755 bin/lxc "$pkgdir"/usr/bin/lxc
-
+
install -Dm755 "$srcdir"/lxd.initd \
"$pkgdir"/etc/init.d/lxd
install -Dm644 "$srcdir"/lxd.confd \
@@ -143,8 +149,6 @@ scripts() {
libs() {
pkgdesc="LXD bundled libraries"
- # do not add sqlite to provides
- options="!tracedeps"
depends=
mkdir -p "$subpkgdir"/usr
mv "$pkgdir"/usr/lib "$subpkgdir"/usr/