aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lxqt-build-tools
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-09 02:24:24 -0300
committerTBK <tbk@jjtc.eu>2019-05-25 05:03:33 +0200
commitaebc15be4c6e706d4fff2c5c1d3a93784bac1b9b (patch)
treed4ce2c7fcbd5189addf920923c3176d6ab8ac184 /testing/lxqt-build-tools
parenta00094247ff1001181d3282d0f848dc56846e92f (diff)
downloadaports-aebc15be4c6e706d4fff2c5c1d3a93784bac1b9b.tar.bz2
aports-aebc15be4c6e706d4fff2c5c1d3a93784bac1b9b.tar.xz
testing/lxqt-build-tools: upgrade to 0.6.0
Closes: GH-7714
Diffstat (limited to 'testing/lxqt-build-tools')
-rw-r--r--testing/lxqt-build-tools/APKBUILD29
1 files changed, 13 insertions, 16 deletions
diff --git a/testing/lxqt-build-tools/APKBUILD b/testing/lxqt-build-tools/APKBUILD
index 3e125d7152..a9438f3b83 100644
--- a/testing/lxqt-build-tools/APKBUILD
+++ b/testing/lxqt-build-tools/APKBUILD
@@ -1,27 +1,25 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-# Maintainer:
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
pkgname=lxqt-build-tools
-pkgver=0.4.0
-pkgrel=1
+pkgver=0.6.0
+pkgrel=0
pkgdesc="Various packaging tools and scripts for LXQt applications"
url="https://lxqt.org/"
-arch="all"
-license="LGPL-2.1"
-depends=""
-makedepends="cmake qt5-qttools-dev"
-install=""
-options="!check"
-subpackages=""
+options="!check" # No testsuite
+arch="noarch"
+license="BSD-3-Clause"
+makedepends="cmake qt5-qtbase-dev glib-dev"
source="https://github.com/lxde/lxqt-build-tools/releases/download/$pkgver/lxqt-build-tools-$pkgver.tar.xz"
-builddir="$srcdir/lxqt-build-tools-$pkgver"
build() {
- cd "$builddir"
+ mkdir build
+ cd build
+
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux \
-DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
- cmake \
+ cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_SHARED_LIBS=True \
@@ -33,8 +31,7 @@ build() {
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
+ make -C build DESTDIR="$pkgdir" install
}
-sha512sums="d84cfce5db9520725e24855f99fb3125f19ff5dbac12ec6d283e9c4483497c675b32061cdea2eda533e57857be4a6eb6020049ae4f593ea61a321b2708604638 lxqt-build-tools-0.4.0.tar.xz"
+sha512sums="f95c47d40f26defa8bc4e13a0449428945c282cb5e2201610e9529bfd5154a438ee9dcc4f556bd76efe13b97533bbed2f49ab5c100225907781093094a692227 lxqt-build-tools-0.6.0.tar.xz"