aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lzlib
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-08-11 16:20:18 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-08-24 22:49:59 +0000
commit45a9b72029f932172a735ab8750e3c911384d8e3 (patch)
treef9873774f244164a1896e8238616b04fa03145dd /testing/lzlib
parentc908b50f57f33d36e0edfb5d3d3a4c18339ccf2e (diff)
downloadaports-45a9b72029f932172a735ab8750e3c911384d8e3.tar.bz2
aports-45a9b72029f932172a735ab8750e3c911384d8e3.tar.xz
testing/lzlib: upgrade to 1.9, modernize and add check
Diffstat (limited to 'testing/lzlib')
-rw-r--r--testing/lzlib/APKBUILD28
1 files changed, 14 insertions, 14 deletions
diff --git a/testing/lzlib/APKBUILD b/testing/lzlib/APKBUILD
index 1c3701f84f..d5edd0eedf 100644
--- a/testing/lzlib/APKBUILD
+++ b/testing/lzlib/APKBUILD
@@ -1,30 +1,30 @@
# Contributor: Klemens Nanni <kl3@posteo.org>
# Maintainer: Klemens Nanni <kl3@posteo.org>
pkgname=lzlib
-pkgver=1.8
+pkgver=1.9
pkgrel=0
pkgdesc="Lzlib is a data compression library"
url="http://www.nongnu.org/lzip/lzlib.html"
arch="all"
license="GPL2+"
-depends=""
-depends_dev=""
-makedepends=""
-install=""
subpackages="$pkgname-doc"
-source="http://download.savannah.gnu.org/releases/lzip/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+source="http://download.savannah.gnu.org/releases/lzip/$pkgname/$pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir/$pkgname-$pkgver"
-builddir="${srcdir}/${pkgname}-${pkgver}"
build() {
- cd "${builddir}"
+ cd "$builddir"
./configure --prefix=/usr
- make || return 1
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
}
package() {
- cd "${builddir}"
- make DESTDIR="${pkgdir}" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
}
-md5sums="251e982d20f10a22069910f2f3951613 lzlib-1.8.tar.gz"
-sha256sums="41bfa82c6ee184ed0884437dc4074ad505e64cb747432cefa97976b89045cbad lzlib-1.8.tar.gz"
-sha512sums="4fe8e28068f67d377bcfb0b7335650acd03565f9c8ac247c87a2b4951b82bae5e8b82d8a537bae84ed13ee09555e7ffbf573a2b3738d9bc86771897981cd549b lzlib-1.8.tar.gz"
+sha512sums="2d36e0b27f544fdab958dbf7d966b41e44c134382ec9f792d94dacf60355eadc25a1cf2b8b7049287995fa5bfc27aec0f3e4253304e3b10813c96b0609408278 lzlib-1.9.tar.gz"