aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lzlib
diff options
context:
space:
mode:
authorKlemens Nanni <kl3@posteo.org>2016-07-05 14:34:04 +0200
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2016-07-07 11:38:04 +0200
commitf7df652f9b010a5388d3f9489a4c134d35459b42 (patch)
tree3740f8d14d3f5b4e165a93bec48b71eb84257c15 /testing/lzlib
parent9515100a5f4a9ad7b6b1d44a5fb9a7b1a6083aa7 (diff)
downloadaports-f7df652f9b010a5388d3f9489a4c134d35459b42.tar.bz2
aports-f7df652f9b010a5388d3f9489a4c134d35459b42.tar.xz
testing/lzlib: new aport
Diffstat (limited to 'testing/lzlib')
-rw-r--r--testing/lzlib/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/lzlib/APKBUILD b/testing/lzlib/APKBUILD
new file mode 100644
index 0000000000..1c3701f84f
--- /dev/null
+++ b/testing/lzlib/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Klemens Nanni <kl3@posteo.org>
+# Maintainer: Klemens Nanni <kl3@posteo.org>
+pkgname=lzlib
+pkgver=1.8
+pkgrel=0
+pkgdesc="Lzlib is a data compression library"
+url="http://www.nongnu.org/lzip/lzlib.html"
+arch="all"
+license="GPL2+"
+depends=""
+depends_dev=""
+makedepends=""
+install=""
+subpackages="$pkgname-doc"
+source="http://download.savannah.gnu.org/releases/lzip/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+
+builddir="${srcdir}/${pkgname}-${pkgver}"
+build() {
+ cd "${builddir}"
+ ./configure --prefix=/usr
+ make || return 1
+}
+
+package() {
+ cd "${builddir}"
+ make DESTDIR="${pkgdir}" install || return 1
+}
+md5sums="251e982d20f10a22069910f2f3951613 lzlib-1.8.tar.gz"
+sha256sums="41bfa82c6ee184ed0884437dc4074ad505e64cb747432cefa97976b89045cbad lzlib-1.8.tar.gz"
+sha512sums="4fe8e28068f67d377bcfb0b7335650acd03565f9c8ac247c87a2b4951b82bae5e8b82d8a537bae84ed13ee09555e7ffbf573a2b3738d9bc86771897981cd549b lzlib-1.8.tar.gz"