aboutsummaryrefslogtreecommitdiffstats
path: root/testing/makeself
diff options
context:
space:
mode:
authorPedro Filipe <xpecex@outlook.com>2018-09-13 22:19:48 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-14 11:44:22 -0300
commit3fb7ffe9ba9287fda7a236e221b5ab5150883c14 (patch)
tree40e43f07dd00030333d4ee7ca0452837b0c8cf37 /testing/makeself
parent1874d82fc679aa7971980674adb504990b160105 (diff)
downloadaports-3fb7ffe9ba9287fda7a236e221b5ab5150883c14.tar.bz2
aports-3fb7ffe9ba9287fda7a236e221b5ab5150883c14.tar.xz
testing/makeself: new aport
Generate a self-extractable compressed tar archive from a directory https://makeself.io/
Diffstat (limited to 'testing/makeself')
-rw-r--r--testing/makeself/APKBUILD21
-rw-r--r--testing/makeself/makeself-header_path.patch12
2 files changed, 33 insertions, 0 deletions
diff --git a/testing/makeself/APKBUILD b/testing/makeself/APKBUILD
new file mode 100644
index 0000000000..ae4615be55
--- /dev/null
+++ b/testing/makeself/APKBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Pedro Filipe <xpecex@outlook.com>
+pkgname=makeself
+pkgver=2.4.0
+pkgrel=0
+pkgdesc="Generate a self-extractable compressed tar archive from a directory"
+options="!check" # Github tarball is incomplete
+url="https://makeself.io/"
+arch="noarch"
+license="GPL-2.0-or-later"
+source="$pkgname-release-$pkgver.tar.gz::https://github.com/megastep/makeself/archive/release-$pkgver.tar.gz
+ makeself-header_path.patch
+ "
+builddir="$srcdir/$pkgname-release-$pkgver"
+
+package() {
+ install -Dm755 makeself.sh "$pkgdir"/usr/bin/makeself
+ install -Dm755 makeself-header.sh "$pkgdir"/usr/bin/makeself-header
+}
+
+sha512sums="f45e349adfb329e75f5fee0053c54e06c7004c12824c935a73a9b9895acb569b339a1acc3ee2b6d69e65cf797120e9d0502ebb6fcceb72fa166cf92f802b1eca makeself-release-2.4.0.tar.gz
+e35228c67a1953cf32af57d011808f70312d1f103505cb4393cc0c1182ed498d05c2ad2c28d8116111ed70479a4fe644b2335ab7e1bb53445a2fbf666396ebdb makeself-header_path.patch"
diff --git a/testing/makeself/makeself-header_path.patch b/testing/makeself/makeself-header_path.patch
new file mode 100644
index 0000000000..eb0aba5234
--- /dev/null
+++ b/testing/makeself/makeself-header_path.patch
@@ -0,0 +1,12 @@
+--- ./makeself.sh
++++ ./makeself.sh
+@@ -185,7 +185,7 @@
+ TAR_EXTRA=""
+ GPG_EXTRA=""
+ DU_ARGS=-ks
+-HEADER=`dirname "$0"`/makeself-header.sh
++HEADER=/usr/bin/makeself-header
+ TARGETDIR=""
+ NOOVERWRITE=n
+ DATE=`LC_ALL=C date`
+