aboutsummaryrefslogtreecommitdiffstats
path: root/testing/marisa-trie
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-09-07 22:28:28 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 17:31:26 -0300
commite16026ddc52a30386b96a8fe6211f638e74efca3 (patch)
treea6ee71231c8bdfe5fc75585e489ba0d954e27843 /testing/marisa-trie
parentc6a805ed6764ea4bd17a657a292940b3a5138605 (diff)
downloadaports-e16026ddc52a30386b96a8fe6211f638e74efca3.tar.bz2
aports-e16026ddc52a30386b96a8fe6211f638e74efca3.tar.xz
testing/marisa-trie: fix building on non-x86 platforms
Diffstat (limited to 'testing/marisa-trie')
-rw-r--r--testing/marisa-trie/APKBUILD18
1 files changed, 14 insertions, 4 deletions
diff --git a/testing/marisa-trie/APKBUILD b/testing/marisa-trie/APKBUILD
index 3319201868..f966471e63 100644
--- a/testing/marisa-trie/APKBUILD
+++ b/testing/marisa-trie/APKBUILD
@@ -18,10 +18,20 @@ prepare() {
}
build() {
- ./configure \
- --prefix=/usr \
- --disable-static \
- --enable-sse2
+ case "$CARCH" in
+ x86|x86_64)
+ ./configure \
+ --prefix=/usr \
+ --disable-static \
+ --enable-sse2
+ ;;
+ *)
+ ./configure \
+ --prefix=/usr \
+ --disable-static
+ ;;
+ esac
+
make
}