aboutsummaryrefslogtreecommitdiffstats
path: root/testing/marisa-trie
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-09-07 22:46:40 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 22:00:44 -0300
commitcb892cb626e7ee35b1685e1572c6d6754d2610b7 (patch)
tree1480bf2370a2448e1e4932fb686f1f46013bd05d /testing/marisa-trie
parent8876377c33bfac787425f29605eef2fff6568b5b (diff)
downloadaports-cb892cb626e7ee35b1685e1572c6d6754d2610b7.tar.bz2
aports-cb892cb626e7ee35b1685e1572c6d6754d2610b7.tar.xz
testing/marisa-trie: improved architecture checking switch
A pkgrel bump isn't necessary as the build output doesn't change, but it'll improve the APKBUILD itself
Diffstat (limited to 'testing/marisa-trie')
-rw-r--r--testing/marisa-trie/APKBUILD18
1 files changed, 7 insertions, 11 deletions
diff --git a/testing/marisa-trie/APKBUILD b/testing/marisa-trie/APKBUILD
index f966471e63..6fa9102c61 100644
--- a/testing/marisa-trie/APKBUILD
+++ b/testing/marisa-trie/APKBUILD
@@ -19,19 +19,15 @@ prepare() {
build() {
case "$CARCH" in
- x86|x86_64)
- ./configure \
- --prefix=/usr \
- --disable-static \
- --enable-sse2
- ;;
- *)
- ./configure \
- --prefix=/usr \
- --disable-static
- ;;
+ x86|x86_64) sse2="--enable-sse2" ;;
+ *) sse2="--disable-sse2" ;;
esac
+ ./configure \
+ --prefix=/usr \
+ --disable-static \
+ $sse2
+
make
}