aboutsummaryrefslogtreecommitdiffstats
path: root/testing/marisa-trie
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-09-07 21:41:59 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 17:13:31 -0300
commite9ac50da5a3afb2d6e9ac24f63bac4724d7435db (patch)
tree38ede57e8db5c52f3230053110b270740196c14d /testing/marisa-trie
parent24c79ec9ea18bb3c97a4560a6a717f8ccdd36966 (diff)
downloadaports-e9ac50da5a3afb2d6e9ac24f63bac4724d7435db.tar.bz2
aports-e9ac50da5a3afb2d6e9ac24f63bac4724d7435db.tar.xz
testing/marisa-trie: new aport
Diffstat (limited to 'testing/marisa-trie')
-rw-r--r--testing/marisa-trie/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/marisa-trie/APKBUILD b/testing/marisa-trie/APKBUILD
new file mode 100644
index 0000000000..3319201868
--- /dev/null
+++ b/testing/marisa-trie/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=marisa-trie
+pkgver=0.2.5
+pkgrel=0
+pkgdesc="Static and space-efficient trie data structure library"
+url="https://github.com/s-yata/marisa-trie"
+arch="all"
+license="BSD-2-Clause"
+makedepends="autoconf automake libtool"
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/s-yata/marisa-trie/archive/v$pkgver.tar.gz"
+
+prepare() {
+ default_prepare
+
+ autoreconf -i
+}
+
+build() {
+ ./configure \
+ --prefix=/usr \
+ --disable-static \
+ --enable-sse2
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="62975a2dacd2a1072c990cd490f866cd5483c069c94a4706baf3ffc21ec43991583a8ef8721c3b841617b0654cbb894698c19759ff12b8887b6fd28939dfb547 marisa-trie-0.2.5.tar.gz"