aboutsummaryrefslogtreecommitdiffstats
path: root/testing/matchbox-keyboard
diff options
context:
space:
mode:
authorDaniele Debernardi <drebrez@gmail.com>2018-10-03 01:00:10 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-06-14 12:01:31 -0300
commitfddab0c7e5919d8093ded0dae882a6896ada7433 (patch)
tree536f9c12ecaa196a692c2e7f0eae0531f10ed30a /testing/matchbox-keyboard
parent1cbe20fef4fb835424ec0c9dd919c06239af244b (diff)
downloadaports-fddab0c7e5919d8093ded0dae882a6896ada7433.tar.bz2
aports-fddab0c7e5919d8093ded0dae882a6896ada7433.tar.xz
testing/matchbox-keyboard: new aport
Diffstat (limited to 'testing/matchbox-keyboard')
-rw-r--r--testing/matchbox-keyboard/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/matchbox-keyboard/APKBUILD b/testing/matchbox-keyboard/APKBUILD
new file mode 100644
index 0000000000..41d584bdab
--- /dev/null
+++ b/testing/matchbox-keyboard/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Daniele Debernardi <drebrez@gmail.com>
+# Maintainer: Daniele Debernardi <drebrez@gmail.com>
+pkgname=matchbox-keyboard
+pkgver=0.1.1
+pkgrel=0
+pkgdesc="An on screen virtual keyboard"
+url="https://www.yoctoproject.org/software-item/matchbox/"
+arch="all"
+license="GPL-2.0-only"
+makedepends="autoconf automake libtool libxft-dev libxtst-dev cairo-dev
+ gtk+3.0-dev gtk+2.0-dev libx11-dev libxrender-dev libfakekey-dev"
+source="http://git.yoctoproject.org/cgit/cgit.cgi/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2"
+options="!check" # No test suite present
+
+build() {
+ autoreconf --install
+ ./configure \
+ --prefix=/usr \
+ --enable-cairo \
+ --enable-gtk-im \
+ --enable-gtk3-im \
+ LDFLAGS="-lXrender -lX11"
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="388298370cd69155a8a11efb2198522fd2757b48861b110998eea38f31ded490d2ba0ee1a715d4a4f76a8e51411e5b3963229938d0be7d44a796e0543b8afa3e matchbox-keyboard-0.1.1.tar.bz2"