aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mate-notification-daemon
diff options
context:
space:
mode:
authorAlan Lacerda <alacerda@alpinelinux.org>2014-12-15 14:49:22 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-12-19 18:33:13 +0000
commiteff71e5b420720fba5f78f1ca70843cb0abafca4 (patch)
tree52f01aeae28e6325f566b35774b5d09d70117681 /testing/mate-notification-daemon
parent424ed507af517c6b8906485d5ba9c7a2dab9644a (diff)
downloadaports-eff71e5b420720fba5f78f1ca70843cb0abafca4.tar.bz2
aports-eff71e5b420720fba5f78f1ca70843cb0abafca4.tar.xz
testing/mate-notification-daemon: new aport
Diffstat (limited to 'testing/mate-notification-daemon')
-rw-r--r--testing/mate-notification-daemon/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/testing/mate-notification-daemon/APKBUILD b/testing/mate-notification-daemon/APKBUILD
new file mode 100644
index 0000000000..6c8ff64364
--- /dev/null
+++ b/testing/mate-notification-daemon/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Alan Lacerda <alacerda@alpinelinux.org>
+# Maintainer:
+pkgname=mate-notification-daemon
+pkgver=1.9.1
+pkgrel=0
+pkgdesc="Small, passive popup dialogs that notify the user of particular events"
+url="https://github.com/mate-desktop/mate-notification-daemon"
+arch="all"
+license="GPL2"
+depends="mate-common"
+depends_dev=""
+makedepends="$depends_dev libwnck-dev libnotify-dev libtool intltool dbus-glib-dev
+ libcanberra-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="http://pub.mate-desktop.org/releases/1.9/$pkgname-$pkgver.tar.xz"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="${pkgdir}" install || return 1
+ find "$pkgdir" -name \*.la -delete
+}
+
+md5sums="d16d7315cadf475dbee5c72492d418aa mate-notification-daemon-1.9.1.tar.xz"
+sha256sums="f00feeb38c56fdcabef5cc9a134a8e9da888033d20bdf60a7649c2f7b5160597 mate-notification-daemon-1.9.1.tar.xz"
+sha512sums="71f5125e47d9b0c0ddb3a80302a3fc66f78c512b775413d2e550aa7b928aea064954a1744bfdad3d1217885fcfff73bd958cbbb3115924b5b282afae00a1b47a mate-notification-daemon-1.9.1.tar.xz"