aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mdbook/APKBUILD
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2019-04-04 10:09:01 -0400
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-04-05 12:15:05 +0000
commitd8d84fd8672056a9fe5ff5022e8d5cb6c173c563 (patch)
tree4c66fd39f296e5b3698b5dec925b3475b2c688d1 /testing/mdbook/APKBUILD
parentb2b1c1be92fd45cbfd5c3128077e271fc2f1ff8c (diff)
downloadaports-d8d84fd8672056a9fe5ff5022e8d5cb6c173c563.tar.bz2
aports-d8d84fd8672056a9fe5ff5022e8d5cb6c173c563.tar.xz
testing/mdbook: new APKBUILD
Diffstat (limited to 'testing/mdbook/APKBUILD')
-rw-r--r--testing/mdbook/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/mdbook/APKBUILD b/testing/mdbook/APKBUILD
new file mode 100644
index 0000000000..1cb9e1ecd8
--- /dev/null
+++ b/testing/mdbook/APKBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Drew DeVault <sir@cmpwn.com>
+pkgname=mdbook
+pkgver=0.2.3
+pkgrel=0
+pkgdesc="mdBook is a utility to create modern online books from Markdown files"
+url="https://rust-lang-nursery.github.io/mdBook"
+arch="x86_64"
+license="MPL-2.0"
+depends=""
+makedepends="rust cargo"
+source="$pkgname-$pkgver.tar.gz::https://github.com/rust-lang-nursery/mdBook/archive/v$pkgver.tar.gz"
+builddir="$srcdir/mdBook-$pkgver"
+export CARGO_HOME="$srcdir"/cargo
+export RUSTFLAGS="-C target-feature=-crt-static"
+
+build() {
+ cd "$builddir"
+ cargo build --release --verbose
+}
+
+check() {
+ cd "$builddir"
+ cargo test --all --release --verbose
+}
+
+package() {
+ cd "$builddir"
+ install -Dm755 target/release/mdbook "$pkgdir"/usr/bin/mdbook
+}
+
+sha512sums="4d339a8f51dd5e80950b0b40ba95225828d3a698ebacef1dd7de0e6771fb74111e821c1b384b334c23d54e8a21ccc14fbefe34081a4e25ecdb2823d42c9ca9b0 mdbook-0.2.3.tar.gz"