aboutsummaryrefslogtreecommitdiffstats
path: root/testing/minio-client
diff options
context:
space:
mode:
authorChloe Kudryavtsev <toast@toastin.space>2019-07-03 17:57:40 -0400
committerLeo <thinkabit.ukim@gmail.com>2019-07-04 00:30:34 -0300
commit494f1f3bd8150ad9f1ce3e8d1162c73c062ec651 (patch)
treeec599795119db4fc3c7bb8f6dd5cae1b95ceb266 /testing/minio-client
parent40825d9f645afea754573a76ad0864355eff7b32 (diff)
downloadaports-494f1f3bd8150ad9f1ce3e8d1162c73c062ec651.tar.bz2
aports-494f1f3bd8150ad9f1ce3e8d1162c73c062ec651.tar.xz
testing/minio-client: upgrade to 0.20190703
Also: - re-enable tests - disable the specific set that's failing It's not particularly trivial in Go, you basically have to filter out the name. This passes in my environment though.
Diffstat (limited to 'testing/minio-client')
-rw-r--r--testing/minio-client/APKBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/testing/minio-client/APKBUILD b/testing/minio-client/APKBUILD
index 23982cc1d9..5f68233192 100644
--- a/testing/minio-client/APKBUILD
+++ b/testing/minio-client/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Chloe Kudryavtsev <toast@toastin.space>
pkgname=minio-client
_pkgname=mc
-_pkgver='RELEASE.2019-06-27T21-31-45Z'
+_pkgver='RELEASE.2019-07-03T18-14-53Z'
pkgver=${_pkgver#*.}
pkgver=${pkgver%T*}
pkgver=0.${pkgver//-}
@@ -13,7 +13,7 @@ license="Apache-2.0"
makedepends="go"
source="$_pkgname-$_pkgver.tar.gz::https://github.com/minio/$_pkgname/archive/$_pkgver.tar.gz"
builddir="$srcdir/src/github.com/minio/$_pkgname"
-options="!check net" # tests seem to lag behind code
+options="net"
export GOPATH="$srcdir"
export CGO_ENABLED=0
@@ -30,7 +30,10 @@ build() {
}
check() {
- GO111MODULE=on go test -tags kqueue ./...
+ # mc/cmd is disabled, seems to be outdated and fails on all my systems
+ GO111MODULE=on go test -tags kqueue $(go list ./... | grep -v \
+ -e cmd \
+ )
}
package() {
@@ -42,4 +45,4 @@ cleanup_srcdir() {
go clean -modcache
default_cleanup_srcdir
}
-sha512sums="2fde68a51d4dfc0c4d7c4733e87430f7338285fd8bedb43e941f5c54d28c04f7b1184694c873e42ed4215453ddee02398ee6f8493b54439e7e25a39320cebebb mc-RELEASE.2019-06-27T21-31-45Z.tar.gz"
+sha512sums="8d364c7b884a1930a300b9e608618b2ea659463bf62fe5280ec6cf0bce26d2a99a52161c71d526ff01ba9efd2de45816321610a21d9eaff6c414bdec8164fca5 mc-RELEASE.2019-07-03T18-14-53Z.tar.gz"