aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mlocate/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-07-16 08:06:29 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-07-16 08:06:29 +0000
commite3adef570713c21c7902f5df0369978e18c445e6 (patch)
treeaacb874946be80ecd3839b2e87ddd6b7ae22dec9 /testing/mlocate/APKBUILD
parent5701f80cfd383c97473a40e81e7b7bb2caeb263f (diff)
parentf1e02f6428610a74f1919f258779729cd90225ee (diff)
downloadaports-e3adef570713c21c7902f5df0369978e18c445e6.tar.bz2
aports-e3adef570713c21c7902f5df0369978e18c445e6.tar.xz
Merge https://github.com/Barthalion/aports
New aports, calcurse, monkey, nethogs, ranger, cmus, abook and mlocate
Diffstat (limited to 'testing/mlocate/APKBUILD')
-rw-r--r--testing/mlocate/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/testing/mlocate/APKBUILD b/testing/mlocate/APKBUILD
new file mode 100644
index 0000000000..f23c465789
--- /dev/null
+++ b/testing/mlocate/APKBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
+
+pkgname=mlocate
+pkgver=0.25
+pkgrel=0
+pkgdesc='An utility to index and quickly search for files by name'
+url='https://fedorahosted.org/mlocate/'
+arch='all'
+license='GPL'
+install="$pkgname.pre-install"
+makedepends='uclibc-dev sed'
+subpackages="$pkgname-doc"
+source="https://fedorahosted.org/releases/m/l/mlocate/mlocate-$pkgver.tar.xz
+ updatedb.conf
+ updatedb.cron.daily"
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+
+ sed -i '/^groupname /s/mlocate/locate/' Makefile.in
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var/lib
+ make
+}
+
+check() {
+ cd $srcdir/$pkgname-$pkgver
+ make check
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+
+ make DESTDIR=$pkgdir install
+
+ ln -s locate $pkgdir/usr/bin/slocate
+ chgrp locate $pkgdir/usr/bin/locate
+ chmod 2755 $pkgdir/usr/bin/locate
+
+ install -dm755 $pkgdir/var/lib
+ install -dm750 -g locate $pkgdir/var/lib/locate
+
+ install -Dm644 ${srcdir}/updatedb.conf $pkgdir/etc/updatedb.conf
+ install -Dm744 ${srcdir}/updatedb.cron.daily $pkgdir/etc/cron.daily/updatedb
+}
+
+md5sums="c6d043b170613b0e327a815b497f680a mlocate-0.25.tar.xz
+465315bfa3380a23fae9a383270cb2ec updatedb.conf
+cde5da81bebad2de556ef2e43d895e13 updatedb.cron.daily"