aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mmc-utils
diff options
context:
space:
mode:
authorOlliver Schinagl <oliver@schinagl.nl>2019-03-03 16:39:15 +0100
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-11 10:58:50 +0000
commitfde964addc014be3dbfc9178803549cd1b01998e (patch)
treeeab43041ae79106e5dd279da8e6a8299e5a1a88d /testing/mmc-utils
parentd8538ea222c894569b535954c1355144ece76c72 (diff)
downloadaports-fde964addc014be3dbfc9178803549cd1b01998e.tar.bz2
aports-fde964addc014be3dbfc9178803549cd1b01998e.tar.xz
testing/mmc-utils: Fix a few small details to the APKBUILD
There are some copy-paste mistakes in the pkgver and url among others. This patch addresses those small oversights. Signed-off-by: Olliver Schinagl <oliver@schinagl.nl>
Diffstat (limited to 'testing/mmc-utils')
-rw-r--r--testing/mmc-utils/APKBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/testing/mmc-utils/APKBUILD b/testing/mmc-utils/APKBUILD
index 7c7126bb1c..d5a35886c8 100644
--- a/testing/mmc-utils/APKBUILD
+++ b/testing/mmc-utils/APKBUILD
@@ -2,9 +2,9 @@
# Maintainer: Olliver Schinagl <oliver@schinagl.nl>
pkgname=mmc-utils
pkgver="4.3.0_git20181024"
-pkgrel=0
+pkgrel=1
pkgdesc="Configure MMC storage devices from userspace."
-url="http://pyropus.ca/software/memtester/"
+url="https://git.kernel.org/pub/scm/linux/kernel/git/cjb/mmc-utils.git"
arch="all"
license="GPL-2.0"
depends=""
@@ -12,19 +12,19 @@ makedepends="linux-headers"
options="!check" # No checks available
subpackages="${pkgname}-doc"
_githash="aef913e31b659462fe6b9320d241676cba97f67b"
-source="https://git.kernel.org/pub/scm/linux/kernel/git/cjb/mmc-utils.git/snapshot/mmc-utils-${_githash}.tar.gz"
+source="https://git.kernel.org/pub/scm/linux/kernel/git/cjb/${pkgname}.git/snapshot/${pkgname}-${_githash}.tar.gz"
+builddir="${srcdir}/${pkgname}-${_githash}"
build()
{
- cd "${srcdir}/mmc-utils-${_githash}"
make
}
package()
{
- cd "${srcdir}/mmc-utils-${_githash}"
make DESTDIR="${pkgdir}" prefix="/usr" install install-man
gzip -c "man/mmc.1" > "mmc.1.gz" && \
install -D -m 644 "mmc.1.gz" "${pkgdir}/usr/share/man/man1/mmc.1.gz"
}
+
sha512sums="afadc665f1c181d4ae2fd5e1e1fc0b05f79a0de039d04ee8db333254aafd7b90edc49accb54d8d7e29a2e541fce34037f83449f91a7b2ebbd2f28e415d9904fd mmc-utils-aef913e31b659462fe6b9320d241676cba97f67b.tar.gz"