aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mmc-utils
diff options
context:
space:
mode:
authorOlliver Schinagl <oliver@schinagl.nl>2019-02-22 16:54:31 +0100
committerKevin Daudt <kdaudt@alpinelinux.org>2019-02-28 21:39:48 +0000
commit2da46a8290a024abb41b97630caf83e8b898bb3b (patch)
tree184a03abd6e4b6d1f22f33f315ede358dd62df2c /testing/mmc-utils
parentef4f1174067eb3a903d8ae7d9f8feaabfab98710 (diff)
downloadaports-2da46a8290a024abb41b97630caf83e8b898bb3b.tar.bz2
aports-2da46a8290a024abb41b97630caf83e8b898bb3b.tar.xz
testing/mmc-utils: new aport
Signed-off-by: Olliver Schinagl <oliver@schinagl.nl>
Diffstat (limited to 'testing/mmc-utils')
-rw-r--r--testing/mmc-utils/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/mmc-utils/APKBUILD b/testing/mmc-utils/APKBUILD
new file mode 100644
index 0000000000..7c7126bb1c
--- /dev/null
+++ b/testing/mmc-utils/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Olliver Schinagl <oliver@schinagl.nl>
+# Maintainer: Olliver Schinagl <oliver@schinagl.nl>
+pkgname=mmc-utils
+pkgver="4.3.0_git20181024"
+pkgrel=0
+pkgdesc="Configure MMC storage devices from userspace."
+url="http://pyropus.ca/software/memtester/"
+arch="all"
+license="GPL-2.0"
+depends=""
+makedepends="linux-headers"
+options="!check" # No checks available
+subpackages="${pkgname}-doc"
+_githash="aef913e31b659462fe6b9320d241676cba97f67b"
+source="https://git.kernel.org/pub/scm/linux/kernel/git/cjb/mmc-utils.git/snapshot/mmc-utils-${_githash}.tar.gz"
+
+build()
+{
+ cd "${srcdir}/mmc-utils-${_githash}"
+ make
+}
+
+package()
+{
+ cd "${srcdir}/mmc-utils-${_githash}"
+ make DESTDIR="${pkgdir}" prefix="/usr" install install-man
+ gzip -c "man/mmc.1" > "mmc.1.gz" && \
+ install -D -m 644 "mmc.1.gz" "${pkgdir}/usr/share/man/man1/mmc.1.gz"
+}
+sha512sums="afadc665f1c181d4ae2fd5e1e1fc0b05f79a0de039d04ee8db333254aafd7b90edc49accb54d8d7e29a2e541fce34037f83449f91a7b2ebbd2f28e415d9904fd mmc-utils-aef913e31b659462fe6b9320d241676cba97f67b.tar.gz"