aboutsummaryrefslogtreecommitdiffstats
path: root/testing/moarvm
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-29 01:18:09 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-29 02:02:26 -0300
commit3dfbd18dc7442ec76aa78f74e2c3a4234d9bdbb6 (patch)
tree2c0430fe40c9b68b7b8e8acbcdeeb8a0acdecf94 /testing/moarvm
parent67d81e8b5014e25dfc20fc9bdf242e48d8416322 (diff)
downloadaports-3dfbd18dc7442ec76aa78f74e2c3a4234d9bdbb6.tar.bz2
aports-3dfbd18dc7442ec76aa78f74e2c3a4234d9bdbb6.tar.xz
testing/moarvm: fix pkgconfig path
Diffstat (limited to 'testing/moarvm')
-rw-r--r--testing/moarvm/APKBUILD9
1 files changed, 2 insertions, 7 deletions
diff --git a/testing/moarvm/APKBUILD b/testing/moarvm/APKBUILD
index c2f91f80c4..d13a9e1be2 100644
--- a/testing/moarvm/APKBUILD
+++ b/testing/moarvm/APKBUILD
@@ -2,32 +2,27 @@
# Maintainer: Curt Tilmes <Curt.Tilmes@nasa.gov>
pkgname=moarvm
pkgver=2019.03
-pkgrel=0
+pkgrel=1
pkgdesc="A VM for NQP And Rakudo Perl 6"
url="http://moarvm.org/"
arch="all"
license="Artistic-2.0"
-depends=""
makedepends="perl libffi-dev"
-install=""
subpackages="$pkgname-dev $pkgname-doc"
source="http://moarvm.org/releases/MoarVM-$pkgver.tar.gz"
builddir="$srcdir"/MoarVM-"$pkgver"
build() {
- cd "$builddir"
unset CPPFLAGS CFLAGS
perl Configure.pl --prefix=/usr --has-libffi
make
}
check() {
- cd "$builddir"
LD_LIBRARY_PATH=. ./moar --version
}
package() {
- cd "$builddir"
install -Dm755 moar "$pkgdir"/usr/bin/moar
install -Dm755 libmoar.so "$pkgdir"/usr/lib/libmoar.so
}
@@ -41,7 +36,7 @@ dev() {
for file in $(find install/usr/share/nqp -type f); do
install -Dm644 ${file} "$subpkgdir"/usr/share/nqp/${file#install/usr/share/nqp}
done
- install -Dm644 install/usr/share/pkgconfig/moar.pc "$subpkgdir"/usr/share/pkgconfig/moar.pc
+ install -Dm644 install/usr/share/pkgconfig/moar.pc "$subpkgdir"/usr/lib/pkgconfig/moar.pc
}
doc() {