aboutsummaryrefslogtreecommitdiffstats
path: root/testing/monero
diff options
context:
space:
mode:
authorAndré Klitzing <aklitzing@gmail.com>2017-09-11 11:39:51 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2017-09-18 14:05:46 +0000
commit5fc23744520682d6db58aefa95e86a3eda3c9f35 (patch)
treefb811cf977f7f64976c1f0d2f875e115f9559292 /testing/monero
parent74127d14fc76bed642233d4dbc7447705b0c2f78 (diff)
downloadaports-5fc23744520682d6db58aefa95e86a3eda3c9f35.tar.bz2
aports-5fc23744520682d6db58aefa95e86a3eda3c9f35.tar.xz
testing/monero: upgrade to 0.11.0.0
Diffstat (limited to 'testing/monero')
-rw-r--r--testing/monero/APKBUILD12
-rw-r--r--testing/monero/easylogging.patch12
-rw-r--r--testing/monero/fix-build-flags-for-ppc64le.patch31
-rw-r--r--testing/monero/libunwind.patch11
4 files changed, 10 insertions, 56 deletions
diff --git a/testing/monero/APKBUILD b/testing/monero/APKBUILD
index 29475e5c25..a9bb03b11b 100644
--- a/testing/monero/APKBUILD
+++ b/testing/monero/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: André Klitzing <aklitzing@gmail.com>
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=monero
-pkgver=0.10.3.1
-pkgrel=2
+pkgver=0.11.0.0
+pkgrel=0
pkgdesc="Secure, private, untraceable cryptocurrency"
url="https://getmonero.org/"
arch="all"
@@ -10,8 +10,6 @@ license="BSD"
makedepends="unbound-dev libressl-dev boost-dev miniupnpc-dev cmake"
source="$pkgname-$pkgver.tar.gz::https://github.com/monero-project/$pkgname/archive/v$pkgver.tar.gz
easylogging.patch
- libunwind.patch
- fix-build-flags-for-ppc64le.patch
"
builddir="$srcdir/"$pkgname-$pkgver
@@ -28,7 +26,5 @@ package() {
install -m755 -t "${pkgdir}"/usr/bin build/bin/*
}
-sha512sums="6856e6078eee5a9036cf7276490a00121b6670b417fd9d8ba8360746af320813fb26f3021079483a61a4bb0179627cfe687435a4146a4ce3cf4d4ad5d500ea95 monero-0.10.3.1.tar.gz
-9d431f87fae5d1fd0d7bb893164c8124bebf682bd3c14b1c4143091837912e36830aa462b05505637f1583595e6259b2d3bbef4706f8875b7ae24c3d0515b255 easylogging.patch
-7dba2020c7cd8e6bcaad778089c4f28132a27c8a18db656c08ab112f81b0faab0eb6aa27f5eafe33f604599db687297627f78cc3ee89f61538007cf8d9c13a42 libunwind.patch
-854d44aee308a5c86e51553767e2b58b25713a7ef9a2ed8650b00d8372f2c19a2d451b87463799495c627b3c133a8c5f1013cdf145c68a82a241b3cfa26b3ec4 fix-build-flags-for-ppc64le.patch"
+sha512sums="c5ac5b08e3ac027ae74c140f4a293dacb642a782a057cfc4ae5be2e2fdc5c669e6f647bc529f4f946345534e59f8d8e48e90c8c53d9871683f549335422488df monero-0.11.0.0.tar.gz
+ff26308bdaf1e0aea9803ece5ec23bebb55d39169e9567c48f4cd4bdceb4fa75cd27fee5bd3d5050273936a3593a29dc2c9d7f5a8dd7a1e0b97a752c48ad4985 easylogging.patch"
diff --git a/testing/monero/easylogging.patch b/testing/monero/easylogging.patch
index f36d96a1e0..6cea439a58 100644
--- a/testing/monero/easylogging.patch
+++ b/testing/monero/easylogging.patch
@@ -1,11 +1,11 @@
--- a/external/easylogging++/easylogging++.h
+++ b/external/easylogging++/easylogging++.h
@@ -195,7 +195,7 @@
- # define ELPP_INTERNAL_INFO(lvl, msg)
+ # define ELPP_INTERNAL_INFO(lvl, msg)
#endif // (defined(ELPP_DEBUG_INFO))
- #if defined(ELPP_STACKTRACE_ON_CRASH)
--# if (ELPP_COMPILER_GCC && !ELPP_MINGW)
-+# if (__has_include(<execinfo.h>) && ELPP_COMPILER_GCC && !ELPP_MINGW)
- # define ELPP_STACKTRACE 1
- # else
+ #if (defined(ELPP_FEATURE_ALL)) || (defined(ELPP_FEATURE_CRASH_LOG))
+-# if (ELPP_COMPILER_GCC && !ELPP_MINGW)
++# if (__has_include(<execinfo.h>) && ELPP_COMPILER_GCC && !ELPP_MINGW)
+ # define ELPP_STACKTRACE 1
+ # else
# define ELPP_STACKTRACE 0
diff --git a/testing/monero/fix-build-flags-for-ppc64le.patch b/testing/monero/fix-build-flags-for-ppc64le.patch
deleted file mode 100644
index 573e268bed..0000000000
--- a/testing/monero/fix-build-flags-for-ppc64le.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- monero-0.10.3.1/CMakeLists.txt
-+++ monero-0.10.3.1/CMakeLists.txt
-@@ -82,6 +82,10 @@
- set(ARM8 1)
- endif()
-
-+if(ARCH_ID STREQUAL "ppc64le")
-+ set(PPC64LE 1)
-+endif()
-+
- if(WIN32 OR ARM)
- set(OPT_FLAGS_RELEASE "-O2")
- else()
-@@ -379,6 +383,8 @@
- message(STATUS "Building on ${CMAKE_SYSTEM_PROCESSOR} for ${ARCH}")
- if(ARCH STREQUAL "default")
- set(ARCH_FLAG "")
-+ elseif(PPC64LE)
-+ set(ARCH_FLAG "-mcpu=${ARCH}")
- else()
- set(ARCH_FLAG "-march=${ARCH}")
- endif()
-@@ -435,7 +441,7 @@
-
- option(NO_AES "Explicitly disable AES support" ${NO_AES})
-
-- if(NOT NO_AES AND NOT ARM)
-+ if(NOT NO_AES AND NOT ARM AND NOT PPC64LE)
- message(STATUS "AES support enabled")
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -maes")
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -maes")
diff --git a/testing/monero/libunwind.patch b/testing/monero/libunwind.patch
deleted file mode 100644
index 90861a52da..0000000000
--- a/testing/monero/libunwind.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -288,7 +288,7 @@
- set(DEFAULT_STACK_TRACE OFF)
- set(LIBUNWIND_LIBRARIES "")
- elseif(CMAKE_C_COMPILER_ID STREQUAL "GNU" AND NOT MINGW)
-- set(DEFAULT_STACK_TRACE ON)
-+ set(DEFAULT_STACK_TRACE OFF)
- set(LIBUNWIND_LIBRARIES "")
- elseif (ARM AND STATIC)
- set(DEFAULT_STACK_TRACE OFF)