aboutsummaryrefslogtreecommitdiffstats
path: root/testing/monero
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-03-13 16:38:10 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-03-13 17:15:34 +0000
commit70ed29eb467d4834d32cca19ee6d7df73f759f5a (patch)
treebae77df0e8fa03c9a45d44f8342e7527bf5a7b0b /testing/monero
parentd08c254c548367a3231279d06a23de38b7a83f81 (diff)
downloadaports-70ed29eb467d4834d32cca19ee6d7df73f759f5a.tar.bz2
aports-70ed29eb467d4834d32cca19ee6d7df73f759f5a.tar.xz
testing/monero: fix version string
Do not add git tag from aports git
Diffstat (limited to 'testing/monero')
-rw-r--r--testing/monero/APKBUILD9
-rw-r--r--testing/monero/version-string.patch13
2 files changed, 19 insertions, 3 deletions
diff --git a/testing/monero/APKBUILD b/testing/monero/APKBUILD
index edfe94fa2b..4e1d34b11c 100644
--- a/testing/monero/APKBUILD
+++ b/testing/monero/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=monero
pkgver=0.14.0.2
-pkgrel=0
+pkgrel=1
pkgdesc="Secure, private, untraceable cryptocurrency"
url="https://getmonero.org/"
arch="all"
@@ -12,15 +12,17 @@ options="!check"
source="$pkgname-$pkgver.tar.gz::https://github.com/monero-project/$pkgname/archive/v$pkgver.tar.gz
easylogging.patch
system-miniupnpc.patch
+ version-string.patch
"
builddir="$srcdir/"$pkgname-$pkgver
build() {
cd "$builddir"
- mkdir build && cd build
+ mkdir -p build && cd build
cmake -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
-DSTACK_TRACE=OFF \
+ -DMANUAL_SUBMODULES=1 \
..
make
}
@@ -33,4 +35,5 @@ package() {
sha512sums="f58718f6ef182796dfe14153c5e8e476289804acc20ce63275e1ca82b1b160473864859dabe42269c20c59054f29dc2a355be24e95466ce78fea15678301b3f4 monero-0.14.0.2.tar.gz
1cc51b85fdf15414421f76de04cf6736db1cbed99d1a08709ff99f2fc2597ccb1cb9940692c2d55fcbb3ed6a85d3704540ddbf86111943fdd09bc8e33aa245e2 easylogging.patch
-70c8e981d87442e0c8eccb6804af8ba78c312cfeb547957b20c8e4e83e533f161ce1b094891a99df4113e901f43954a0f1473e39781e8dae77faa0726132563b system-miniupnpc.patch"
+70c8e981d87442e0c8eccb6804af8ba78c312cfeb547957b20c8e4e83e533f161ce1b094891a99df4113e901f43954a0f1473e39781e8dae77faa0726132563b system-miniupnpc.patch
+087e48b0507c0fb7cc9dbab05b0373b61687de3935642299c6df0194539934e7cccad497435c32291c063b10f4d91d4fbc98d81e269148c4e14780ed38d43559 version-string.patch"
diff --git a/testing/monero/version-string.patch b/testing/monero/version-string.patch
new file mode 100644
index 0000000000..98dd8a2ca4
--- /dev/null
+++ b/testing/monero/version-string.patch
@@ -0,0 +1,13 @@
+diff --git a/cmake/Version.cmake b/cmake/Version.cmake
+index 3677e80..490de2c 100644
+--- a/cmake/Version.cmake
++++ b/cmake/Version.cmake
+@@ -32,7 +32,7 @@ function (write_static_version_header hash)
+ endfunction ()
+
+ find_package(Git QUIET)
+-if ("$Format:$" STREQUAL "")
++if ("$Format:$" STREQUAL "" OR NOT EXISTS .git)
+ # We're in a tarball; use hard-coded variables.
+ write_static_version_header("release")
+ elseif (GIT_FOUND OR Git_FOUND)