aboutsummaryrefslogtreecommitdiffstats
path: root/testing/monero
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-20 13:32:34 +0300
committerprspkt <prspkt@protonmail.com>2019-06-20 14:06:51 +0300
commit22167855cb4c705576d6a4897653c54e83160212 (patch)
tree24f120e5acc2b9afde49dc3c8963c58db7c7faed /testing/monero
parent03f3832d1af5044151aaaf8cc734ad7deee9bf4b (diff)
downloadaports-22167855cb4c705576d6a4897653c54e83160212.tar.bz2
aports-22167855cb4c705576d6a4897653c54e83160212.tar.xz
testing/monero: clarify license, modernize
Diffstat (limited to 'testing/monero')
-rw-r--r--testing/monero/APKBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/testing/monero/APKBUILD b/testing/monero/APKBUILD
index fa0235da78..9e644fd221 100644
--- a/testing/monero/APKBUILD
+++ b/testing/monero/APKBUILD
@@ -6,18 +6,17 @@ pkgrel=0
pkgdesc="Secure, private, untraceable cryptocurrency"
url="https://getmonero.org/"
arch="all"
-license="BSD"
-makedepends="unbound-dev openssl-dev boost-dev miniupnpc-dev cmake cppzmq zeromq-dev rapidjson-dev readline-dev libsodium-dev"
+license="BSD-3-Clause"
+makedepends="boost-dev cmake cppzmq libsodium-dev miniupnpc-dev openssl-dev
+ rapidjson-dev readline-dev unbound-dev zeromq-dev"
options="!check"
-source="$pkgname-$pkgver.tar.gz::https://github.com/monero-project/$pkgname/archive/v$pkgver.tar.gz
+source="$pkgname-$pkgver.tar.gz::https://github.com/monero-project/monero/archive/v$pkgver.tar.gz
easylogging.patch
system-miniupnpc.patch
version-string.patch
"
-builddir="$srcdir/"$pkgname-$pkgver
build() {
- cd "$builddir"
mkdir -p build && cd build
cmake -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
@@ -28,7 +27,6 @@ build() {
}
package() {
- cd "$builddir"
mkdir -p "${pkgdir}"/usr/bin
install -m755 -t "${pkgdir}"/usr/bin build/bin/*
}