aboutsummaryrefslogtreecommitdiffstats
path: root/testing/monero
diff options
context:
space:
mode:
authorAndré Klitzing <aklitzing@gmail.com>2017-06-17 00:38:39 +0200
committerTimo Teräs <timo.teras@iki.fi>2017-06-20 07:50:35 +0000
commit711e23bd51010b5757171e9183516e6127783ffc (patch)
tree103dad52187af5e26766fb1240c66177a585a7b2 /testing/monero
parent5a9f09fdb0d9016db63f68af0715e9f0e7a95db7 (diff)
downloadaports-711e23bd51010b5757171e9183516e6127783ffc.tar.bz2
aports-711e23bd51010b5757171e9183516e6127783ffc.tar.xz
testing/monero: new aport
Diffstat (limited to 'testing/monero')
-rw-r--r--testing/monero/APKBUILD30
-rw-r--r--testing/monero/libunwind.patch11
2 files changed, 41 insertions, 0 deletions
diff --git a/testing/monero/APKBUILD b/testing/monero/APKBUILD
new file mode 100644
index 0000000000..6206fa93f5
--- /dev/null
+++ b/testing/monero/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: André Klitzing <aklitzing@gmail.com>
+# Maintainer: André Klitzing <aklitzing@gmail.com>
+pkgname=monero
+pkgver=0.10.3.1
+pkgrel=0
+pkgdesc="Secure, private, untraceable cryptocurrency"
+url="https://getmonero.org/"
+arch="all"
+license="BSD"
+makedepends="unbound-dev libressl-dev boost-dev libunwind-dev miniupnpc-dev cmake"
+source="$pkgname-$pkgver.tar.gz::https://github.com/monero-project/$pkgname/archive/v$pkgver.tar.gz
+ libunwind.patch
+ "
+builddir="$srcdir/"$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ mkdir build && cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
+ make
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p "${pkgdir}"/usr/bin
+ install -m755 -t "${pkgdir}"/usr/bin build/bin/*
+}
+
+sha512sums="6856e6078eee5a9036cf7276490a00121b6670b417fd9d8ba8360746af320813fb26f3021079483a61a4bb0179627cfe687435a4146a4ce3cf4d4ad5d500ea95 monero-0.10.3.1.tar.gz
+7dba2020c7cd8e6bcaad778089c4f28132a27c8a18db656c08ab112f81b0faab0eb6aa27f5eafe33f604599db687297627f78cc3ee89f61538007cf8d9c13a42 libunwind.patch"
diff --git a/testing/monero/libunwind.patch b/testing/monero/libunwind.patch
new file mode 100644
index 0000000000..90861a52da
--- /dev/null
+++ b/testing/monero/libunwind.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -288,7 +288,7 @@
+ set(DEFAULT_STACK_TRACE OFF)
+ set(LIBUNWIND_LIBRARIES "")
+ elseif(CMAKE_C_COMPILER_ID STREQUAL "GNU" AND NOT MINGW)
+- set(DEFAULT_STACK_TRACE ON)
++ set(DEFAULT_STACK_TRACE OFF)
+ set(LIBUNWIND_LIBRARIES "")
+ elseif (ARM AND STATIC)
+ set(DEFAULT_STACK_TRACE OFF)