aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mongodb/mongodb.pre-install
diff options
context:
space:
mode:
authorFilipp Andronov <filipp.andronov@gmail.com>2015-05-16 21:43:04 +0700
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2015-06-27 20:36:57 +0200
commit11de19231cd990e2700f20635f3413f8d2be3016 (patch)
treefe20a325ab539873980542185d8233ada2b192a9 /testing/mongodb/mongodb.pre-install
parentfe594b5019dc0a4d2abd0e30a61d4f695e9737c8 (diff)
downloadaports-11de19231cd990e2700f20635f3413f8d2be3016.tar.bz2
aports-11de19231cd990e2700f20635f3413f8d2be3016.tar.xz
testing/mongodb: new aport
Things to be complete: 1. Build is only for x86_64, because I have to made a few hacks in code. Most critical one is __ELF_NATIVE_CLASS 2. No tc-malloc. It doesnt build, so system allocator instead. Im working on gpreftools package... 3. No heap usage statistics: always returns 0. It is broken in mongodb for 64bit architecture and also musl mallocinfo is not compatible with glibc. So I just comment out heap reporting code, see comments in APKBUILD 4. Use more system libs, yaml & boost are from the top of my mind. Boost make compilation fails, but should be easy to fix 5. Enable mongodb tests during build. Im just not sure how that should be done in Alpine, i.e _where_ in build lifecycle tests should run
Diffstat (limited to 'testing/mongodb/mongodb.pre-install')
-rw-r--r--testing/mongodb/mongodb.pre-install4
1 files changed, 4 insertions, 0 deletions
diff --git a/testing/mongodb/mongodb.pre-install b/testing/mongodb/mongodb.pre-install
new file mode 100644
index 0000000000..e02453f7b9
--- /dev/null
+++ b/testing/mongodb/mongodb.pre-install
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+adduser -D -G daemon -h /var/lib/mongodb -s /sbin/nologin mongodb
+exit 0