aboutsummaryrefslogtreecommitdiffstats
path: root/testing/monkey/APKBUILD
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <b@bpiotrowski.pl>2012-07-12 12:49:56 +0200
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2012-07-12 14:09:27 +0200
commit348dff0e529b2ddbaf277689747316ce697098b7 (patch)
tree8b2f985b39e12c9c5057fcdf6de8a9e2772f6008 /testing/monkey/APKBUILD
parent3fd12a0011693045356304a007f062c2f02669cd (diff)
downloadaports-348dff0e529b2ddbaf277689747316ce697098b7.tar.bz2
aports-348dff0e529b2ddbaf277689747316ce697098b7.tar.xz
testing/monkey: new aport
Diffstat (limited to 'testing/monkey/APKBUILD')
-rw-r--r--testing/monkey/APKBUILD61
1 files changed, 61 insertions, 0 deletions
diff --git a/testing/monkey/APKBUILD b/testing/monkey/APKBUILD
new file mode 100644
index 0000000000..32082b7ccf
--- /dev/null
+++ b/testing/monkey/APKBUILD
@@ -0,0 +1,61 @@
+# Maintainer: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
+
+pkgname=monkey
+pkgver=1.0.1
+pkgrel=0
+pkgdesc='A fast and lightweight HTTP server designed for embedded devices.'
+url='http://monkey-project.com/'
+license='GPL2'
+arch='all'
+makedepends='bash'
+subpackages="$pkgname-doc"
+source="http://monkey-project.com/releases/1.0/$pkgname-$pkgver.tar.gz
+ strsignal.patch
+ monkey.initd
+ monkey.confd"
+
+prepare() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ # Use POSIX-compliant strsignal instead SYS_SIGLIST
+ patch -Np0 -i "$srcdir"/strsignal.patch || return 1
+
+ # Don't install the banana script, use OpenRC daemon instead
+ sed -i '/install -m 755 bin\/banana/d' configure || return 1
+ rm man/banana.1 || return 1
+
+ # Run monkey as http user
+ sed -i '737s/nobody/http/' configure || return 1
+}
+
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ ./configure \
+ --prefix=/usr \
+ --bindir=/usr/bin \
+ --sysconfdir=/etc/$pkgname \
+ --mandir=/usr/share/man \
+ --datadir=/var/www \
+ --logdir=/var/log/$pkgname \
+ --plugdir=/usr/lib/$pkgname \
+ || return 1
+
+ make || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR=$pkgdir install || return 1
+
+ install -D -m0755 "$srcdir"/monkey.initd \
+ "$pkgdir"/etc/init.d/monkey || return 1
+ install -D -m0644 "$srcdir"/monkey.confd \
+ "$pkgdir"/etc/conf.d/monkey || return 1
+}
+
+md5sums="5e08e4089e8b41ea90b0c98d6ca6433e monkey-1.0.1.tar.gz
+4e99ccbfbd00b17023c7b82e466c7aee strsignal.patch
+6630131d3ea75dbbf1033a4acc8cf983 monkey.initd
+71805f446a12d747c52e18b8ac4b4704 monkey.confd"