aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mono
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-10-23 17:29:13 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-10-23 18:25:10 -0300
commitbaac63e7d6903f3a8af0a72dbf06fd067564e921 (patch)
tree637e802ef73d8e5b5f55ea4f86e8e89d6b19a250 /testing/mono
parent23bc57c79511f119429b0c4fb5cfbed77398a0a3 (diff)
downloadaports-baac63e7d6903f3a8af0a72dbf06fd067564e921.tar.bz2
aports-baac63e7d6903f3a8af0a72dbf06fd067564e921.tar.xz
testing/mono: switch to python3
Diffstat (limited to 'testing/mono')
-rw-r--r--testing/mono/APKBUILD12
-rw-r--r--testing/mono/python3.patch60
2 files changed, 66 insertions, 6 deletions
diff --git a/testing/mono/APKBUILD b/testing/mono/APKBUILD
index 26e5733939..751abc7c29 100644
--- a/testing/mono/APKBUILD
+++ b/testing/mono/APKBUILD
@@ -3,22 +3,21 @@
# Maintainer:
pkgname=mono
pkgver=5.20.1.19
-pkgrel=0
+pkgrel=1
pkgdesc="Free implementation of the .NET platform including runtime and compiler"
url="https://www.mono-project.com/"
arch="x86_64 x86 armv7"
license="MIT"
-depends="python2"
+depends="python3"
depends_dev="libgdiplus-dev zlib-dev"
-makedepends="$depends_dev autoconf automake cmake libtool linux-headers paxmark python2"
+makedepends="$depends_dev autoconf automake cmake libtool linux-headers paxmark"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="https://download.mono-project.com/sources/mono/mono-${pkgver/_/~}.tar.bz2
+ python3.patch
"
prepare() {
default_prepare
- cd "$builddir"
-
# Remove hardcoded lib directory from the config.
sed -i 's|$mono_libdir/||g' data/config.in
@@ -66,4 +65,5 @@ package() {
rm ./usr/lib/libMonoSupportW.*
}
-sha512sums="498fffc70c524cf21477196b6fdc3c5d03a719098c0a0ca40c29e239588675ddc0538659e4119171316f8f35555fcd42390d474dff0b795bf67188bc34a35ae0 mono-5.20.1.19.tar.bz2"
+sha512sums="498fffc70c524cf21477196b6fdc3c5d03a719098c0a0ca40c29e239588675ddc0538659e4119171316f8f35555fcd42390d474dff0b795bf67188bc34a35ae0 mono-5.20.1.19.tar.bz2
+6d16a04f350f406d631626c43e783dda9bf1ee87fd97f376b089b547f4d1851f5724f4fe2ad4c6adb1e2a8a3fe5dce6a4dd2da4abbe9f865bf0101831ec63632 python3.patch"
diff --git a/testing/mono/python3.patch b/testing/mono/python3.patch
new file mode 100644
index 0000000000..38f3081e62
--- /dev/null
+++ b/testing/mono/python3.patch
@@ -0,0 +1,60 @@
+diff --git a/mono/mini/Makefile.am b/mono/mini/Makefile.am
+index 6c840f88b..402a8c8f6 100644
+--- a/mono/mini/Makefile.am
++++ b/mono/mini/Makefile.am
+@@ -742,7 +742,7 @@ MemoryIntrinsics.dll: MemoryIntrinsics.il
+
+ GENMDESC_OPTS=
+
+-GENMDESC_PRG=python $(srcdir)/genmdesc.py $(target_define) $(srcdir)
++GENMDESC_PRG=python3 $(srcdir)/genmdesc.py $(target_define) $(srcdir)
+
+ cpu-wasm.h: mini-ops.h cpu-wasm.md
+ $(GENMDESC_PRG) cpu-wasm.h wasm_desc $(srcdir)/cpu-wasm.md
+diff --git a/mono/mini/Makefile.am.in b/mono/mini/Makefile.am.in
+index 6c840f88b..402a8c8f6 100755
+--- a/mono/mini/Makefile.am.in
++++ b/mono/mini/Makefile.am.in
+@@ -742,7 +742,7 @@ MemoryIntrinsics.dll: MemoryIntrinsics.il
+
+ GENMDESC_OPTS=
+
+-GENMDESC_PRG=python $(srcdir)/genmdesc.py $(target_define) $(srcdir)
++GENMDESC_PRG=python3 $(srcdir)/genmdesc.py $(target_define) $(srcdir)
+
+ cpu-wasm.h: mini-ops.h cpu-wasm.md
+ $(GENMDESC_PRG) cpu-wasm.h wasm_desc $(srcdir)/cpu-wasm.md
+diff --git a/mono/mini/Makefile.in b/mono/mini/Makefile.in
+index d3555b8c7..8a7e85ad4 100644
+--- a/mono/mini/Makefile.in
++++ b/mono/mini/Makefile.in
+@@ -1212,7 +1212,7 @@ libmonoincludedir = $(includedir)/mono-$(API_VER)/mono/jit
+ libmonoinclude_HEADERS = jit.h
+ CSFLAGS = -unsafe -nowarn:0219,0169,0414,0649,0618
+ GENMDESC_OPTS =
+-GENMDESC_PRG = python $(srcdir)/genmdesc.py $(target_define) $(srcdir)
++GENMDESC_PRG = python3 $(srcdir)/genmdesc.py $(target_define) $(srcdir)
+ LLVM_AOT_RUNTIME_OPTS = $(if $(LLVM),--llvm,)
+ GSHAREDVT_RUNTIME_OPTS = $(if $(GSHAREDVT),-O=gsharedvt,)
+ fullaot_regtests = $(regtests)
+diff --git a/mono/mini/genmdesc.py b/mono/mini/genmdesc.py
+index 987332bdf..c3593ba96 100755
+--- a/mono/mini/genmdesc.py
++++ b/mono/mini/genmdesc.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/python3
+
+ #
+ # This tool is used to generate the cpu-<ARCH>.h files used by the JIT. The input is the
+diff --git a/scripts/mono-heapviz b/scripts/mono-heapviz
+index 27b6f7f60..d19ca33d9 100755
+--- a/scripts/mono-heapviz
++++ b/scripts/mono-heapviz
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/python3
+
+ # Generate a heap visualization for SGen from the heap dump written by
+ # mono if the MONO_GC_DEBUG is set to something like
+