aboutsummaryrefslogtreecommitdiffstats
path: root/testing/motif/03-no-demos.patch
diff options
context:
space:
mode:
authorIsaac Dunham <ibid.ag@gmail.com>2014-06-21 14:40:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-06-23 06:41:47 +0000
commit96d9a81946ebca7dcaa1a8ae9712ee477a156606 (patch)
tree88ef61a0abbd1c78ae5f5314997e1420e23cefe8 /testing/motif/03-no-demos.patch
parentd28d72a16f7697a518150bf27feb26ac317bce28 (diff)
downloadaports-96d9a81946ebca7dcaa1a8ae9712ee477a156606.tar.bz2
aports-96d9a81946ebca7dcaa1a8ae9712ee477a156606.tar.xz
Add motif
Manually sending, since git send-email is being recalcitrant. This will allow me to package nedit and a number of other things. From 3077415e704bee5da76d1000e66bb8e25c0248cf Mon Sep 17 00:00:00 2001 From: Isaac Dunham <ibid.ag@gmail.com> Date: Thu, 19 Jun 2014 05:41:45 +0000 Subject: [PATCH] Add Motif. Motif is an X intrinsics based toolkit which was once widely used. This version is built with Xft support, but not PNG, JPEG, or Xprint. The patches are snarfed from Debian; not all are needed.
Diffstat (limited to 'testing/motif/03-no-demos.patch')
-rw-r--r--testing/motif/03-no-demos.patch53
1 files changed, 53 insertions, 0 deletions
diff --git a/testing/motif/03-no-demos.patch b/testing/motif/03-no-demos.patch
new file mode 100644
index 0000000000..03953c4f8f
--- /dev/null
+++ b/testing/motif/03-no-demos.patch
@@ -0,0 +1,53 @@
+Description: Add option to disable building of demos
+Forwarded: http://bugs.motifzone.net/show_bug.cgi?id=1575
+Author: Graham Inggs <graham@nerve.org.za>
+Last-Update: 2013-01-09
+--- a/configure.ac
++++ b/configure.ac
+@@ -311,7 +311,20 @@
+ doc/man/man5/Makefile \
+ tools/Makefile \
+ tools/wml/Makefile \
+-demos/Makefile \
++lib/Xm/xmstring.list \
++])
++
++AC_ARG_ENABLE(demos, [ --disable-demos
++ Disable building demos])
++
++if test x$enable_demos = x
++then
++ enable_demos="yes"
++fi
++
++if test "$enable_demos" = "yes"
++then
++ AC_CONFIG_FILES([demos/Makefile
+ demos/lib/Makefile \
+ demos/lib/Xmd/Makefile \
+ demos/lib/Wsm/Makefile \
+@@ -395,6 +408,11 @@
+ demos/doc/programGuide/ch17/Makefile \
+ demos/doc/programGuide/ch17/simple_drop/Makefile \
+ demos/doc/programGuide/ch17/simple_drag/Makefile \
+-lib/Xm/xmstring.list \
+-])
++ ])
++ MAYBE_DEMOS=demos
++else
++ MAYBE_DEMOS=
++fi
++AC_SUBST(MAYBE_DEMOS)
++
+ AC_OUTPUT
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -29,6 +29,7 @@
+ tools \
+ clients \
+ doc \
+- demos
++ $(MAYBE_DEMOS)
++
+ AUTOMAKE_OPTIONS = 1.4
+ ACLOCAL_AMFLAGS = -I .