aboutsummaryrefslogtreecommitdiffstats
path: root/testing/motion/pthread.patch
diff options
context:
space:
mode:
authorGP Orcullo <kinsamanka@gmail.com>2017-08-31 17:14:32 +0800
committerTimo Teräs <timo.teras@iki.fi>2017-09-06 07:10:38 +0000
commit66ff8434575d6f12b1d7ca893d22df1a55ff84e3 (patch)
tree1e7f38b1bbb17e594c24103ec0906b23dea2de15 /testing/motion/pthread.patch
parent1e776e60847dfb253fc3e76286e40384ad9d8d96 (diff)
downloadaports-66ff8434575d6f12b1d7ca893d22df1a55ff84e3.tar.bz2
aports-66ff8434575d6f12b1d7ca893d22df1a55ff84e3.tar.xz
testing/motion: Updated to version 4.0.1 with ffmpeg
- updated to the latest release - re-enabled ffmpeg support - switched to openrc init - used /var/lib/motion for storage - disabled cpu optimization
Diffstat (limited to 'testing/motion/pthread.patch')
-rw-r--r--testing/motion/pthread.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/motion/pthread.patch b/testing/motion/pthread.patch
new file mode 100644
index 0000000000..570849729b
--- /dev/null
+++ b/testing/motion/pthread.patch
@@ -0,0 +1,23 @@
+configure doesn't generate proper pthread support
+
+--- motion-4.0.1/configure.ac
++++ ./configure.ac
+@@ -188,7 +188,8 @@
+ pthread_create(0,0,0,0); pthread_cleanup_pop(0); ],
+ [PTHREAD_LIB=yes])
+
+-if test x$PTHREAD_LIB != xyes; then
++# this test should fail but it doesn't on alpine
++if test x$PTHREAD_LIB = xyes; then
+
+ if test "${FreeBSD}" != ""; then
+ TEMP_LIBS="$TEMP_LIBS -pthread"
+@@ -213,7 +214,7 @@
+ CFLAGS="$TEMP_CFLAGS"
+ LIBS="$TEMP_LIBS"
+ AC_LINK_IFELSE(
+- [AC_LANG_PROGRAM([[#include <pthread.h>]], [[ pthread_setname_np(pthread_self(), "name")]])],
++ [AC_LANG_PROGRAM([[#include <pthread.h>]], [[ pthread_getname_np(pthread_self(), "name", 0)]])],
+ [AC_DEFINE([[HAVE_PTHREAD_SETNAME_NP]], [[1]], [Define if you have pthread_setname_np function.])
+ AC_MSG_RESULT([[yes]])],
+ [AC_MSG_RESULT([[no]])] )