aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mozjs-38
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2017-06-05 20:45:39 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-06-05 20:45:39 +0000
commit66dfddae65d7db2864e258fd2d5c65e0a33ee203 (patch)
treed2b6e08609b33569a259542dc13d42a692e1e358 /testing/mozjs-38
parentf62be4e846a1ede7e7c6f0c350c535ccdd003171 (diff)
downloadaports-66dfddae65d7db2864e258fd2d5c65e0a33ee203.tar.bz2
aports-66dfddae65d7db2864e258fd2d5c65e0a33ee203.tar.xz
testing/mozjs-38: new aport
Diffstat (limited to 'testing/mozjs-38')
-rw-r--r--testing/mozjs-38/APKBUILD44
-rw-r--r--testing/mozjs-38/fix-fortify-system-wrappers.patch13
2 files changed, 57 insertions, 0 deletions
diff --git a/testing/mozjs-38/APKBUILD b/testing/mozjs-38/APKBUILD
new file mode 100644
index 0000000000..05ec4a1623
--- /dev/null
+++ b/testing/mozjs-38/APKBUILD
@@ -0,0 +1,44 @@
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=mozjs-38
+pkgver=38.8.0
+pkgrel=0
+pkgdesc="standalone mozilla javascript engine"
+url="https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey/Releases/38"
+arch="all"
+license="LGPL"
+depends=""
+depends_dev="icu-dev nspr-dev libffi-dev readline-dev"
+makedepends="$depends_dev python2"
+install=""
+subpackages="$pkgname-dev"
+source="https://ftp.mozilla.org/pub/firefox/releases/${pkgver}esr/source/firefox-${pkgver}esr.source.tar.bz2
+ fix-fortify-system-wrappers.patch"
+builddir="$srcdir/mozilla-esr38"
+_builddir="$builddir/js/src"
+options="!check"
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --with-system-icu \
+ --with-system-nspr \
+ --enable-system-ffi \
+ --with-system-zlib \
+ --with-intl-api \
+ --enable-ctypes \
+ --enable-threadsafe \
+ --enable-shared-js \
+ --enable-gcgenerational \
+ --disable-optimize \
+ --enable-pie
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+ rm -f "$pkgdir"/usr/lib/*.ajs
+}
+
+sha512sums="fcd2497a60176b8403a1793d1ad0a1c96a0a60217c2d4d7acd0506abf6810892bd51fd113d8f952f92b20032efc539a6b1233d8d124c2eb72d726b0935c04d65 firefox-38.8.0esr.source.tar.bz2
+a4f613ba4e977796fa024824940bbc1d3df549138612bfcdbb643753d54d4d5bfbf601a12f76312a87ecc7ec595ff34ddefb47c2cd1a6e31252c1fa3a263bdae fix-fortify-system-wrappers.patch"
diff --git a/testing/mozjs-38/fix-fortify-system-wrappers.patch b/testing/mozjs-38/fix-fortify-system-wrappers.patch
new file mode 100644
index 0000000000..f020a2f408
--- /dev/null
+++ b/testing/mozjs-38/fix-fortify-system-wrappers.patch
@@ -0,0 +1,13 @@
+The wrapper features.h gets pulled in by system headers causing thigns to
+break. We work around it by simply not wrap features.h
+
+--- a/config/system-headers.orig
++++ b/config/system-headers
+@@ -422,7 +422,6 @@
+ extras.h
+ fabdef.h
+ fcntl.h
+-features.h
+ fibdef.h
+ File.h
+ filehdr.h