aboutsummaryrefslogtreecommitdiffstats
path: root/testing/muffin
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2014-02-10 11:26:08 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2014-02-10 11:26:18 +0000
commitcd2cb9634f45d1aa6dab01fa14ca71ad1c4f9297 (patch)
treebd0ff61734c37be996ce2385cbb5255b79d44663 /testing/muffin
parent254fe8d3cbd1355089ab957cbe86d62cb63fca3e (diff)
downloadaports-cd2cb9634f45d1aa6dab01fa14ca71ad1c4f9297.tar.bz2
aports-cd2cb9634f45d1aa6dab01fa14ca71ad1c4f9297.tar.xz
testing/muffin: compile glib schemas
Diffstat (limited to 'testing/muffin')
-rw-r--r--testing/muffin/APKBUILD4
-rw-r--r--testing/muffin/muffin.post-deinstall6
-rw-r--r--testing/muffin/muffin.post-install6
-rw-r--r--testing/muffin/muffin.post-upgrade6
4 files changed, 20 insertions, 2 deletions
diff --git a/testing/muffin/APKBUILD b/testing/muffin/APKBUILD
index 1447db7d6a..39302b913c 100644
--- a/testing/muffin/APKBUILD
+++ b/testing/muffin/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=muffin
pkgver=2.0.5
-pkgrel=0
+pkgrel=1
pkgdesc="Cinnamon window manager based on Mutter"
url="https://github.com/linuxmint/muffin"
arch="all"
@@ -12,7 +12,7 @@ depends_dev="glib-dev dconf-dev libcanberra-dev gobject-introspection-dev gtk+3.
cinnamon-desktop-dev clutter-dev startup-notification-dev"
makedepends="$depends_dev autoconf automake libtool gnome-common intltool gnome-doc-utils
zenity"
-install=""
+install="$pkgname.post-install $pkgname.post-upgrade $pkgname.post-deinstall"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="$pkgname-$pkgver.tar.gz::https://github.com/linuxmint/muffin/archive/$pkgver.tar.gz"
diff --git a/testing/muffin/muffin.post-deinstall b/testing/muffin/muffin.post-deinstall
new file mode 100644
index 0000000000..772791e6f3
--- /dev/null
+++ b/testing/muffin/muffin.post-deinstall
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+echo "Compiling glib schemas"
+
+/usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas
+
diff --git a/testing/muffin/muffin.post-install b/testing/muffin/muffin.post-install
new file mode 100644
index 0000000000..772791e6f3
--- /dev/null
+++ b/testing/muffin/muffin.post-install
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+echo "Compiling glib schemas"
+
+/usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas
+
diff --git a/testing/muffin/muffin.post-upgrade b/testing/muffin/muffin.post-upgrade
new file mode 100644
index 0000000000..772791e6f3
--- /dev/null
+++ b/testing/muffin/muffin.post-upgrade
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+echo "Compiling glib schemas"
+
+/usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas
+