aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mutter/APKBUILD
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-04-26 13:21:43 +0000
committerTBK <tbk@jjtc.eu>2019-05-25 18:05:41 +0200
commitd7ee181fd9fbe296662c6831103a39b4656e0e62 (patch)
tree262ebea03a11710a6373a1d00cb211a84b7a1ace /testing/mutter/APKBUILD
parentb31e59f7a01e2a96778fffd5cd17f672bee78e26 (diff)
downloadaports-d7ee181fd9fbe296662c6831103a39b4656e0e62.tar.bz2
aports-d7ee181fd9fbe296662c6831103a39b4656e0e62.tar.xz
testing/mutter: update to 3.32.2
Closes: GH-7379
Diffstat (limited to 'testing/mutter/APKBUILD')
-rw-r--r--testing/mutter/APKBUILD48
1 files changed, 24 insertions, 24 deletions
diff --git a/testing/mutter/APKBUILD b/testing/mutter/APKBUILD
index 79f4b622c8..024c04c195 100644
--- a/testing/mutter/APKBUILD
+++ b/testing/mutter/APKBUILD
@@ -1,44 +1,44 @@
-# Maintainer:
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=mutter
-pkgver=3.28.2
+pkgver=3.32.2
pkgrel=0
pkgdesc="clutter-based window manager and compositor"
-url="https://github.com/GNOME/mutter"
+url="https://wiki.gnome.org/Projects/Mutter/"
arch="all"
-license="GPL"
-depends="xkeyboard-config zenity gsettings-desktop-schemas"
+license="GPL-2.0-or-later"
+depends="xkeyboard-config zenity gsettings-desktop-schemas xorg-server-xwayland"
makedepends="gnome-desktop-dev libcanberra-dev upower-dev json-glib-dev
libxkbcommon-dev libxkbfile-dev wayland-protocols clutter-dev cogl-dev
libgudev-dev libinput-dev gnome-common itstool libxml2-utils
- libxcomposite-dev libxdamage-dev"
+ libxcomposite-dev libxdamage-dev elogind-dev meson py3-setuptools
+ gnome-settings-daemon-dev libice-dev libsm-dev startup-notification-dev
+ xorg-server xorg-server-xwayland"
+options="!check" # Can't be run with release builds
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz
- fix-format-error.patch"
-builddir="$srcdir/mutter-$pkgver"
+ fixudev-req.patch"
build() {
- cd "$builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
+ meson \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
- --disable-wayland \
- --enable-compile-warnings=minimum
- make
-}
-
-check() {
- cd "$builddir"
- make check
+ --buildtype=release \
+ -Degl_device=true \
+ -Dudev=true \
+ -Dnative_backend=true \
+ -Dintrospection=true \
+ -Dxwayland_path=/usr/bin/Xwayland \
+ -Dremote_desktop=false \
+ . output
+ ninja -C output
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" ninja -C output install
}
-sha512sums="b5b718eb5b8b9317b17a08c059d01760aa60edd46abc4b3780bd7e15e1c9702ac7808ee8039d0ec59fd7b9ddfcbc518019fac57c12742e7d4e46fa75b276d84f mutter-3.28.2.tar.xz
-034b7dfb8a785e00ca08d6b727f58f62442e191e1eb7abb9ed4eebc6b644eb74502200487c6af1ecc50640dfe670d9d0b5b1bffb02dc473ad8734917c68afbf7 fix-format-error.patch"
+sha512sums="e4494d028ae71441fbdc584bd8acd9c2559d52ac72402bad9a7cb43f4f519487d11df6453172fd27a9df7f2cade020d6317931613bd0be343c66170e6cda0269 mutter-3.32.2.tar.xz
+6f21171bbd0ad0fc67cbaf5fb1478b22b482a9ae33b9328cc51a5dd31bcf7d95cd41e6cbbac21d3d8801cc064a62a64ae38ed7d0501ab605b861058c32f3bc30 fixudev-req.patch"