aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mwoffliner
diff options
context:
space:
mode:
authorOleg Titov <oleg.titov@gmail.com>2019-10-02 13:39:19 -0500
committerRasmus Thomsen <oss@cogitri.dev>2019-10-20 22:25:18 +0200
commit458a82cfd1c88803464d681a09e57c01df2de2ed (patch)
tree4400f4833d5e87d79123e7d9d3efc204bf2c0b9e /testing/mwoffliner
parent165d9f90c3ee8b93e6dfcc58f9ac0e81581ebfb5 (diff)
downloadaports-458a82cfd1c88803464d681a09e57c01df2de2ed.tar.bz2
aports-458a82cfd1c88803464d681a09e57c01df2de2ed.tar.xz
testing/mwoffliner: new aport
https://openzim.org Mediawiki motorised wiki scraper
Diffstat (limited to 'testing/mwoffliner')
-rw-r--r--testing/mwoffliner/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/mwoffliner/APKBUILD b/testing/mwoffliner/APKBUILD
new file mode 100644
index 0000000000..391e4ddf77
--- /dev/null
+++ b/testing/mwoffliner/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Oleg Titov <oleg.titov@gmail.com>
+# Maintainer: Oleg Titov <oleg.titov@gmail.com>
+pkgname=mwoffliner
+pkgver=1.9.12
+pkgrel=0
+pkgdesc="Scrape any online Mediawiki motorised wiki to your local filesystem"
+url="https://github.com/openzim/mwoffliner"
+arch="x86_64"
+license="GPL-3.0-or-later"
+options="!check" # no test suite from upstream
+depends="nodejs-npm redis libc6-compat"
+makedepends="python2 autoconf automake chrpath libjpeg-turbo-dev nasm zlib-dev
+ libzim-dev bash"
+subpackages="$pkgname-doc"
+source="mwoffliner-$pkgver.tar.gz::https://github.com/openzim/mwoffliner/archive/v$pkgver.tar.gz"
+
+build() {
+ npm install
+}
+
+check() {
+ npm test
+}
+
+package() {
+ install -d "$pkgdir"/usr/share/doc/$pkgname "$pkgdir"/usr/lib/node_modules/$pkgname
+ cp -a lib node_modules package*.json "$pkgdir"/usr/lib/node_modules/$pkgname
+ ln -s /usr/lib/node_modules/$pkgname/bin/$pkgname "$pkgdir"/usr/lib/node_modules/$pkgname
+
+ install -Dm644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
+
+ # Strip all the rpath that include /home
+ local scandir="$pkgdir"/usr/lib/node_modules/mwoffliner/node_modules/@openzim/libzim/
+ scanelf --recursive --rpath --etype ET_DYN "$scandir" | \
+ awk '/home/{print $3;}' | xargs chrpath --delete
+}
+
+sha512sums="fd6a16beb045837eb3f21720842e0e40e5fa01943a7861ae7dde02b071360130bf0b523a8e8ae324e2e8469857ccab0d46554e53d9387f2d715be47ec51ebc09 mwoffliner-1.9.12.tar.gz"