aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mynewt-newt
diff options
context:
space:
mode:
authorKeith Maxwell <keith.maxwell@gmail.com>2019-04-08 12:49:39 +0100
committerCarlo Landmeter <clandmeter@alpinelinux.org>2019-04-08 14:44:51 +0000
commitecf3646cffa789e9665e82909791da305873b378 (patch)
tree5f352c487a76dea20f5d029820a2b32bce9184ae /testing/mynewt-newt
parent11ec831257657b4c77649f6bbf9a8312293181c1 (diff)
downloadaports-ecf3646cffa789e9665e82909791da305873b378.tar.bz2
aports-ecf3646cffa789e9665e82909791da305873b378.tar.xz
testing/mynewt-newt: rename from testing/newt
Renamed to avoid an exact pkgname clash with main/newt mynewt-newt is the package name used in other distribtions: https://repology.org/project/mynewt-newt/versions
Diffstat (limited to 'testing/mynewt-newt')
-rw-r--r--testing/mynewt-newt/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/mynewt-newt/APKBUILD b/testing/mynewt-newt/APKBUILD
new file mode 100644
index 0000000000..d69cc29c60
--- /dev/null
+++ b/testing/mynewt-newt/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Oleg Titov <oleg.titov@gmail.com>
+# Maintainer: Oleg Titov <oleg.titov@gmail.com>
+pkgname=mynewt-newt
+pkgver=1.5.0
+_ver=${pkgver//./_}_tag
+pkgrel=0
+pkgdesc="Apache Newt is a smart build and package management tool for Apache Mynewt Operating System"
+url="https://mynewt.apache.org"
+arch="x86_64 x86"
+license="Apache-2.0"
+options="!check" # No test suit
+depends="git"
+makedepends="go"
+subpackages="$pkgname-doc"
+source="mynewt-newt-$pkgver.tar.gz::https://github.com/apache/mynewt-newt/archive/mynewt_${_ver}.tar.gz"
+builddir="$srcdir/mynewt-newt-mynewt_${_ver}"
+
+build() {
+ cd "$builddir"
+ ./build.sh
+}
+
+package() {
+ cd "$builddir"
+ install -Dm 755 newt/newt ${pkgdir}/usr/bin/newt
+
+ install -Dm 644 -t ${pkgdir}/usr/share/licenses/${pkgname}/ LICENSE
+ install -Dm 644 -t ${pkgdir}/usr/share/doc/${pkgname}/ README.md
+}
+
+sha512sums="1e32db93946f75cc22f35d65c15bb4e505e4eed72e929e0864d13604c4f91da1b301ca5cf91650b4fedf47c2328bacc501fdc16b845b2f244d610aa9c710beee mynewt-newt-1.5.0.tar.gz"