aboutsummaryrefslogtreecommitdiffstats
path: root/testing/nanomsg/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-07 15:16:30 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-12 16:19:30 -0300
commitec974c91c0ade95f4aafccc46c747e9fab62860c (patch)
treea3b22f567946a01f96f38c61869873fbe072db6c /testing/nanomsg/APKBUILD
parentb9a810e6ff14f55db988db8648f523ffeefe3e03 (diff)
downloadaports-ec974c91c0ade95f4aafccc46c747e9fab62860c.tar.bz2
aports-ec974c91c0ade95f4aafccc46c747e9fab62860c.tar.xz
testing/nanomsg: modernize
Diffstat (limited to 'testing/nanomsg/APKBUILD')
-rw-r--r--testing/nanomsg/APKBUILD7
1 files changed, 1 insertions, 6 deletions
diff --git a/testing/nanomsg/APKBUILD b/testing/nanomsg/APKBUILD
index 03067cb54e..0da06096e6 100644
--- a/testing/nanomsg/APKBUILD
+++ b/testing/nanomsg/APKBUILD
@@ -7,16 +7,13 @@ pkgdesc="Socket library that provides several common communication patterns"
url="http://nanomsg.org"
arch="all !armhf !armv7" # armhf: segfaults in 2 tests
license="MIT"
-depends_dev="asciidoctor xmlto"
-makedepends="$depends_dev cmake"
+makedepends="asciidoctor xmlto cmake"
options="libtool"
subpackages="$pkgname-dev $pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/nanomsg/nanomsg/archive/$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$builddir"
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib .
@@ -24,12 +21,10 @@ build() {
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}