aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ndctl
diff options
context:
space:
mode:
authorBreno Leitao <breno.leitao@gmail.com>2017-03-23 00:59:20 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-08-29 11:10:56 +0000
commit73f82bca80ae2ff7fcb516e8ed62627656cb641d (patch)
tree1f24bab5fce60db8ebc987d0038f6b1db44a040d /testing/ndctl
parentd7d376a0f62d4550aecd10b33efd9f330a57173a (diff)
downloadaports-73f82bca80ae2ff7fcb516e8ed62627656cb641d.tar.bz2
aports-73f82bca80ae2ff7fcb516e8ed62627656cb641d.tar.xz
testing/ndctl: Adapt to abuild version 3
Currently ndctl does not contain the check() primitive, and it is using || return 1 all the time. Adapting this package to the new abuild version 3 era.
Diffstat (limited to 'testing/ndctl')
-rw-r--r--testing/ndctl/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/testing/ndctl/APKBUILD b/testing/ndctl/APKBUILD
index ca49a40a82..cd5e7d3d2a 100644
--- a/testing/ndctl/APKBUILD
+++ b/testing/ndctl/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Breno Leitao <breno.leitao@gmail.com>
pkgname=ndctl
pkgver=57.1
-pkgrel=0
+pkgrel=1
pkgdesc="Utility library for managing the libnvdimm (non-volatile memory device) sub-system in the Linux kernel"
url="https://github.com/pmem/ndctl"
arch="all"
@@ -31,6 +31,11 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install