aboutsummaryrefslogtreecommitdiffstats
path: root/testing/nemo-qml-plugin-dbus
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-09-07 21:30:57 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 16:34:09 -0300
commit5c8792e3ca6358a4158b482ffcadb4fa3f973749 (patch)
tree3dd01d6ddb5f84817aade1b6e5beac4ce55aee89 /testing/nemo-qml-plugin-dbus
parentb59700ece3070a831a9c160b78f874cabe6d460f (diff)
downloadaports-5c8792e3ca6358a4158b482ffcadb4fa3f973749.tar.bz2
aports-5c8792e3ca6358a4158b482ffcadb4fa3f973749.tar.xz
testing/nemo-qml-plugin-dbus: new aport
Diffstat (limited to 'testing/nemo-qml-plugin-dbus')
-rw-r--r--testing/nemo-qml-plugin-dbus/APKBUILD32
-rw-r--r--testing/nemo-qml-plugin-dbus/fix-makefile.patch28
2 files changed, 60 insertions, 0 deletions
diff --git a/testing/nemo-qml-plugin-dbus/APKBUILD b/testing/nemo-qml-plugin-dbus/APKBUILD
new file mode 100644
index 0000000000..ab7022e6b6
--- /dev/null
+++ b/testing/nemo-qml-plugin-dbus/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=nemo-qml-plugin-dbus
+pkgver=2.1.21
+pkgrel=0
+pkgdesc="Nemo's QML plugin for DBus"
+url="https://git.merproject.org/mer-core/nemo-qml-plugin-dbus"
+arch="all"
+license="BSD-3-Clause"
+depends_dev="qt5-qtbase-dev qt5-qtdeclarative-dev"
+makedepends="$depends_dev"
+subpackages="$pkgname-dev"
+source="https://git.merproject.org/mer-core/nemo-qml-plugin-dbus/-/archive/$pkgver/nemo-qml-plugin-dbus-$pkgver.tar.gz"
+options="!check" # No tests
+
+build() {
+ qmake-qt5
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ INSTALL_ROOT="$pkgdir" make install
+
+ # Remove installed tests
+ rm -r "$pkgdir"/opt
+}
+
+sha512sums="1e6cd57d2008e708d0e63b20f8a357e0e21643bd9c6e3e7fe8acd464b225e736daa3ebb45e99b1593347059eb9bbcc5e38d4da71d12f367c968c905f227d0d68 nemo-qml-plugin-dbus-2.1.21.tar.gz"
diff --git a/testing/nemo-qml-plugin-dbus/fix-makefile.patch b/testing/nemo-qml-plugin-dbus/fix-makefile.patch
new file mode 100644
index 0000000000..9e52bedd89
--- /dev/null
+++ b/testing/nemo-qml-plugin-dbus/fix-makefile.patch
@@ -0,0 +1,28 @@
+diff --git a/Makefile b/Makefile
+index 92522fb..fb2d3f5 100644
+--- a/Makefile
++++ b/Makefile
+@@ -3,11 +3,11 @@
+ NAME = pure-maps
+ VERSION = 1.21.1
+ RELEASE = $(NAME)-$(VERSION)
+-DESTDIR =
+ PREFIX = /usr
+ EXEDIR = $(DESTDIR)$(PREFIX)/bin
+ EXE = $(EXEDIR)/$(NAME)
+ DATADIR = $(DESTDIR)$(PREFIX)/share/$(NAME)
++LANGDIR = $(DESTDIR)$(PREFIX)/share/locale
+ DESKTOPDIR = $(DESTDIR)$(PREFIX)/share/applications
+ ICONDIR = $(DESTDIR)$(PREFIX)/share/icons/hicolor
+ METADIR = $(DESTDIR)$(PREFIX)/share/metainfo
+@@ -19,8 +19,8 @@ LCONVERT = $(or $(wildcard /usr/lib/qt5/bin/lconvert),\
+
+ define install-translation =
+ # GNU gettext translations for Python use.
+- mkdir -p $(DATADIR)/locale/$(1)/LC_MESSAGES
+- msgfmt po/$(1).po -o $(DATADIR)/locale/$(1)/LC_MESSAGES/pure-maps.mo
++ mkdir -p $(LANGDIR)/$(1)/LC_MESSAGES
++ msgfmt po/$(1).po -o $(LANGDIR)/$(1)/LC_MESSAGES/pure-maps.mo
+ # Qt linguist translations for QML use.
+ mkdir -p $(DATADIR)/translations
+ $(LCONVERT) -o $(DATADIR)/translations/$(NAME)-$(1).qm po/$(1).po