aboutsummaryrefslogtreecommitdiffstats
path: root/testing/neofetch
diff options
context:
space:
mode:
authordawidd6 <dawidd0811@gmail.com>2017-06-23 01:02:22 +0200
committerFrancesco Colista <fcolista@alpinelinux.org>2017-07-10 16:33:35 +0000
commitd81d608f0d56ed02e02d63dd0b32ac1ad99b84e0 (patch)
tree486b2e004ac527b2bb967ffcd7ed8a91f3ac93d4 /testing/neofetch
parentfe62ef2fe6a814b4dd28a135a87e651683b3c6ef (diff)
downloadaports-d81d608f0d56ed02e02d63dd0b32ac1ad99b84e0.tar.bz2
aports-d81d608f0d56ed02e02d63dd0b32ac1ad99b84e0.tar.xz
testing/neofetch: new aport
Neofetch is a CLI system information tool written in BASH. Neofetch displays information about your system next to an image, your OS logo, or any ASCII file of your choice. The main purpose of Neofetch is to be used in screenshots to show other users what OS/Distro you're running, what Theme/Icons you're using etc.
Diffstat (limited to 'testing/neofetch')
-rw-r--r--testing/neofetch/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/neofetch/APKBUILD b/testing/neofetch/APKBUILD
new file mode 100644
index 0000000000..94e4253d17
--- /dev/null
+++ b/testing/neofetch/APKBUILD
@@ -0,0 +1,23 @@
+# Contributor: Dawid Dziurla <dawidd0811@gmail.com>
+# Maintainer: Dawid Dziurla <dawidd0811@gmail.com>
+pkgname=neofetch
+pkgver=3.2.0
+pkgrel=0
+pkgdesc="A CLI system information tool written in BASH that supports displaying images."
+url="https://github.com/dylanaraps/neofetch"
+arch="noarch"
+license="MIT"
+makedepends="make"
+depends="bash"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
+options="!check"
+builddir="$srcdir/$pkgname-$pkgver"
+
+package()
+{
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+sha512sums="790dd282b99437a416f25a895d5a3359be31d162447e2f59863c635c144045a6b81672e4469ca9b6eeba56fc927e787a67f0a317309bbc0f52500b0f9e072764 neofetch-3.2.0.tar.gz"