aboutsummaryrefslogtreecommitdiffstats
path: root/testing/neomutt/APKBUILD
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2017-08-20 01:09:16 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2017-08-20 01:16:21 +0200
commitd66e763719c409faf9c5e01d0f5ef901a74030f1 (patch)
treeca3a3fa245429a565f733b804ce630f2a0736e52 /testing/neomutt/APKBUILD
parent9f4ff4ed2cc53b09053296c5c8007bbc54d18597 (diff)
downloadaports-d66e763719c409faf9c5e01d0f5ef901a74030f1.tar.bz2
aports-d66e763719c409faf9c5e01d0f5ef901a74030f1.tar.xz
testing/notmuch: properly enable notmuch and gpgme support
For some reason it seems to be necessary to pass the configure options for these two features as short options. Otherwise the following warning shows up: configure: WARNING: invalid host type: –-enable-notmuch No idea why this is happening. GNU autotools is a mess and I don't want to look at it any longer.
Diffstat (limited to 'testing/neomutt/APKBUILD')
-rw-r--r--testing/neomutt/APKBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/testing/neomutt/APKBUILD b/testing/neomutt/APKBUILD
index eb3d3a3398..26f659d998 100644
--- a/testing/neomutt/APKBUILD
+++ b/testing/neomutt/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=neomutt
pkgver=20170714
-pkgrel=0
+pkgrel=1
pkgdesc="Mutt with miscellaneous fixes and feature patches"
url="https://www.neomutt.org/"
arch="all"
@@ -26,7 +26,7 @@ prepare() {
build() {
cd "$builddir"
- ./configure \
+ ./configure -enable-notmuch -enable-gpgme \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
@@ -35,11 +35,10 @@ build() {
--localstatedir=/var \
--with-docdir=/usr/share/doc/$pkgname \
--with-mailpath=/var/spool/mail \
- –-enable-notmuch \
--with-gdbm \
--with-ssl \
--with-sasl
- #make
+ make
}
package() {