aboutsummaryrefslogtreecommitdiffstats
path: root/testing/newlib
diff options
context:
space:
mode:
authorMarian Buschsieweke <marian.buschsieweke@ovgu.de>2019-03-14 10:55:25 +0100
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-04-03 10:06:14 +0000
commitf1d8b5d0585dc2573528d8c100b2bb487a270efc (patch)
tree0dbbfbdddf54c06097dd373a9a0b7a9b3554b0ef /testing/newlib
parentbc948f396a0595a876c99e0db06a6b495654cfe7 (diff)
downloadaports-f1d8b5d0585dc2573528d8c100b2bb487a270efc.tar.bz2
aports-f1d8b5d0585dc2573528d8c100b2bb487a270efc.tar.xz
testing/newlib: Fixed dependencies
Currently each flavor of newlib depended on all toolchains, e.g. newlib-arm-none-eabi would not only pull in binutils and gcc for the target arm-none-eabi, but all others as well. This commit changes the behavior so that each newlib version only pulls in the corresponding toolchain.
Diffstat (limited to 'testing/newlib')
-rw-r--r--testing/newlib/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/testing/newlib/APKBUILD b/testing/newlib/APKBUILD
index f0cdfb92aa..3d09b2fba9 100644
--- a/testing/newlib/APKBUILD
+++ b/testing/newlib/APKBUILD
@@ -8,7 +8,7 @@ _targets="
"
pkgname="$_pkgbase"
pkgver="3.0.0.20180831"
-pkgrel=0
+pkgrel=1
pkgdesc="A C standard library implementation intended for use on embedded systems"
url="http://www.sourceware.org/newlib/"
makedepends="texinfo"
@@ -22,7 +22,7 @@ options="!check"
for target in $_targets; do
targetnorm="${target//-/_}"
subpackages="${_pkgbase}-${target}:${targetnorm} ${subpackages}"
- depends="binutils-${target} gcc-${target} ${depends}"
+ makedepends="binutils-${target} gcc-${target} ${makedepends}"
done
builddir="$srcdir/$_pkgbase-$pkgver"
@@ -109,6 +109,7 @@ package() {
_install_subpkg() {
pkgdesc="A C standard library implementation intended for ${target}"
target="${subpkgname#$_pkgbase-}"
+ depends="binutils-${target} gcc-${target} ${depends}"
mkdir -p "$subpkgdir"
# install nano version
cd "${builddir}/build-${target}-nano"