aboutsummaryrefslogtreecommitdiffstats
path: root/testing/nghttp2
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-08-14 08:54:15 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2015-08-14 08:54:29 +0200
commita522332ddd322e9ab6d984ea5e79dc01ef4476b3 (patch)
treeab9791ec57065c42cb27c1ddbd9c890d3dad42a3 /testing/nghttp2
parent6772ec423070c5d22a3ecd2caffa8ba414ec23e8 (diff)
downloadaports-a522332ddd322e9ab6d984ea5e79dc01ef4476b3.tar.bz2
aports-a522332ddd322e9ab6d984ea5e79dc01ef4476b3.tar.xz
testing/nghttp2: new aport
Experimental HTTP/2 client, server and proxy https://nghttp2.org/ ref #4520
Diffstat (limited to 'testing/nghttp2')
-rw-r--r--testing/nghttp2/APKBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/testing/nghttp2/APKBUILD b/testing/nghttp2/APKBUILD
new file mode 100644
index 0000000000..d5a26c28e1
--- /dev/null
+++ b/testing/nghttp2/APKBUILD
@@ -0,0 +1,54 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer:
+pkgname=nghttp2
+pkgver=1.2.0
+pkgrel=0
+pkgdesc="Experimental HTTP/2 client, server and proxy"
+url="https://nghttp2.org/"
+arch="all"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="$depends_dev libev-dev openssl-dev zlib-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
+source="https://github.com/tatsuhiro-t/nghttp2/releases/download/v$pkgver/nghttp2-$pkgver.tar.xz"
+
+_builddir="$srcdir"/nghttp2-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --disable-ptyhon-bindings \
+ --disable-static \
+ --without-libxml2 \
+ --without-spdylay \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="86cb96848518cc067c7d55de0385bc02 nghttp2-1.2.0.tar.xz"
+sha256sums="9e4a419c835b6cfa08ff9743f823638d32d8516aa3abfc86598272d173bc558f nghttp2-1.2.0.tar.xz"
+sha512sums="96e1bcc66dc9b2ff75bad1ab46cfd36c0fb7bec1938a59d1b2ed4c7d7bc8c7f220cccd9292e885d9b3dd4c1834d7010be337f083126ccc324aaa9b05d4a60795 nghttp2-1.2.0.tar.xz"