aboutsummaryrefslogtreecommitdiffstats
path: root/testing/nlohmann-json
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-22 20:07:16 -0300
committerFrancesco Colista <fcolista@alpinelinux.org>2019-05-27 15:23:42 +0000
commit9ef14175ca8d69cfff52f836d31c1c4e1e48879c (patch)
tree9b256bf6e167c941d08f9399f48b8a775a73aa56 /testing/nlohmann-json
parent20bc7ecd3939d5cd5478d48bc297777644d8a9f6 (diff)
downloadaports-9ef14175ca8d69cfff52f836d31c1c4e1e48879c.tar.bz2
aports-9ef14175ca8d69cfff52f836d31c1c4e1e48879c.tar.xz
testing/nlohmann-json: modernize
Diffstat (limited to 'testing/nlohmann-json')
-rw-r--r--testing/nlohmann-json/APKBUILD5
1 files changed, 0 insertions, 5 deletions
diff --git a/testing/nlohmann-json/APKBUILD b/testing/nlohmann-json/APKBUILD
index e7b1c721dc..01733cd9f6 100644
--- a/testing/nlohmann-json/APKBUILD
+++ b/testing/nlohmann-json/APKBUILD
@@ -7,25 +7,20 @@ pkgdesc="JSON for Modern C++"
url="https://github.com/nlohmann/json"
arch="noarch"
license="MIT"
-depends=""
makedepends="doxygen"
-install=""
subpackages="nlohmann-json-doc"
source="nlohmann-json-$pkgver.tar.gz::https://github.com/nlohmann/json/archive/v$pkgver.tar.gz"
builddir="$srcdir/json-$pkgver"
build() {
- cd "$builddir"
make -C doc
}
check() {
- cd "$builddir"
if [ "$CARCH" != "s390x" ]; then make check-fast; fi
}
package() {
- cd "$builddir"
mkdir -p "$pkgdir/usr/include"
mv include/nlohmann "$pkgdir/usr/include"
}