aboutsummaryrefslogtreecommitdiffstats
path: root/testing/nlohmann-json
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-08-18 23:27:29 +0200
committerMilan P. Stanić <mps@arvanta.net>2019-08-18 23:43:22 +0200
commite6a1fc9118ccf2653e8186d8a9341a0a031c6944 (patch)
treefe1d9d95736337b50a3b00cd510d6372b7afcae2 /testing/nlohmann-json
parent216d4bc93667ebd0784df11443efd46043b8c47e (diff)
downloadaports-e6a1fc9118ccf2653e8186d8a9341a0a031c6944.tar.bz2
aports-e6a1fc9118ccf2653e8186d8a9341a0a031c6944.tar.xz
testing/nlohmann-json: disable test-unicode_all on aarch64
Diffstat (limited to 'testing/nlohmann-json')
-rw-r--r--testing/nlohmann-json/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/testing/nlohmann-json/APKBUILD b/testing/nlohmann-json/APKBUILD
index b1dd0c6e23..3289ddd232 100644
--- a/testing/nlohmann-json/APKBUILD
+++ b/testing/nlohmann-json/APKBUILD
@@ -22,7 +22,12 @@ build() {
}
check() {
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ local skipped_tests=
+ if [ "$CARCH" = "aarch64" ]; then
+ # test-unicode_all takes too long and times out
+ skipped_tests="$skipped_tests|test-unicode_all"
+ fi
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E "($skipped_tests)"
}
package() {