aboutsummaryrefslogtreecommitdiffstats
path: root/testing/nomp
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-12-27 09:25:53 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-12-27 09:25:53 +0000
commit02e2d0d6ed6999c6fc63eedf7e52ec4f7e13c208 (patch)
tree65f9fae67866863cfad7dac38f68d22d389ea80d /testing/nomp
parent594d7c34a3fdeb1ca6c9febbeca1b58d703e51d7 (diff)
downloadaports-02e2d0d6ed6999c6fc63eedf7e52ec4f7e13c208.tar.bz2
aports-02e2d0d6ed6999c6fc63eedf7e52ec4f7e13c208.tar.xz
testing/nomp: new aport
Diffstat (limited to 'testing/nomp')
-rw-r--r--testing/nomp/APKBUILD30
-rw-r--r--testing/nomp/make-path.patch13
2 files changed, 43 insertions, 0 deletions
diff --git a/testing/nomp/APKBUILD b/testing/nomp/APKBUILD
new file mode 100644
index 0000000000..c27e6874c5
--- /dev/null
+++ b/testing/nomp/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=nomp
+pkgver=0.1
+pkgrel=0
+pkgdesc="Ncurses OpenVAS Manager Protocol"
+url="https://github.com/git-rep/nomp"
+arch="all"
+license="GPL2"
+makedepends="openssl-dev libxml++-dev ncurses-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/git-rep/$pkgname/archive/v$pkgver.tar.gz
+make-path.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="b2804a32998454a02941ae949ce61a33 nomp-0.1.tar.gz
+9339a38fed11bea5e3eccefe7b12f48f make-path.patch"
+sha256sums="da6cfc9226e5c5315a13879900509037b795e866bc628a4114ec2001120b5f3e nomp-0.1.tar.gz
+2cb14891c17f4225ea6da9d8a58fdc7ee7ea0f1e6b31b0eac74a8065c8f9c094 make-path.patch"
+sha512sums="2eeda71892ce998df4f86eeb7cc9b19981844a547b4fce13528f8e9b4f7d7afae60aac035bae74f8a2cf7cf93063b497844e9f6627abf8215925758a93e58140 nomp-0.1.tar.gz
+9713d125666993e69d7dae5dd253eee884090ce2087c419214beeb4c133e2e3ac219f8bac097e97952ff41066bfb6a6ad731b390c2aadba43ddd72f96f9443f2 make-path.patch"
diff --git a/testing/nomp/make-path.patch b/testing/nomp/make-path.patch
new file mode 100644
index 0000000000..5d69caf4b8
--- /dev/null
+++ b/testing/nomp/make-path.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index c53a4b7..05aa874 100644
+--- a/Makefile
++++ b/Makefile
+@@ -6,7 +6,7 @@ BUILDDIR = .build
+ SOURCES = $(wildcard src/*.cc)
+ OBJECTS = $(patsubst $(SOURCEDIR)/%.cc,$(BUILDDIR)/%.o,$(SOURCES))
+ DEPS := $(OBJECTS:.o=.d)
+-PREFIX = /usr/local
++PREFIX = /usr
+ TARGET = nomp
+
+ .SILENT: