aboutsummaryrefslogtreecommitdiffstats
path: root/testing/nototools
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-10-16 14:37:23 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-10-19 21:23:57 +0000
commitc50f33a30db7c3c4c6d33fb868934113a8d4ccbf (patch)
treee7198f99f775f29fe7f10a2b77e432a8efb9d52b /testing/nototools
parent225e389a87f90dfce90af37db5c8da3b976b1a53 (diff)
downloadaports-c50f33a30db7c3c4c6d33fb868934113a8d4ccbf.tar.bz2
aports-c50f33a30db7c3c4c6d33fb868934113a8d4ccbf.tar.xz
testing/nototools: upgrade to 0_git20191015
Closes !447
Diffstat (limited to 'testing/nototools')
-rw-r--r--testing/nototools/APKBUILD31
-rw-r--r--testing/nototools/unichr.patch11
2 files changed, 13 insertions, 29 deletions
diff --git a/testing/nototools/APKBUILD b/testing/nototools/APKBUILD
index 8aa4c67a9b..db6c9f4211 100644
--- a/testing/nototools/APKBUILD
+++ b/testing/nototools/APKBUILD
@@ -1,36 +1,31 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
-# Maintainer:
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=nototools
-pkgver=20171030
-_commit=3627598b4e858c6eb43e9ee76400d7072570a3e8
+pkgver=0_git20191015
+_commit="0154a4f9937fab2c9265bfc4f08ed8e82c39b52c"
pkgrel=0
pkgdesc="Noto fonts support tools and scripts"
url="https://www.google.com/get/noto/"
arch="noarch"
license="Apache-2.0"
-depends="python2"
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
-source="$pkgname-$pkgver.tar.gz::https://github.com/googlei18n/$pkgname/archive/$_commit.tar.gz
- data_path.patch
- unichr.patch"
+depends="python3"
+makedepends="python3-dev py-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://github.com/googlei18n/nototools/archive/$_commit.tar.gz
+ data_path.patch"
builddir="$srcdir/$pkgname-$_commit"
build() {
- cd "$builddir"
- python2 setup.py build || return 1
+ python3 setup.py build
}
package() {
- cd "$builddir"
- python2 setup.py install --prefix=/usr \
- --root="$pkgdir" || return 1
+ python3 setup.py install \
+ --prefix=/usr \
+ --root="$pkgdir"
mkdir -p "$pkgdir"/usr/share/nototools
cp -r third_party "$pkgdir"/usr/share/nototools
}
-sha512sums="d33ff3ac320b64cc41f5bf7f703084d5a954ca31cde55f1802344568a82421f7055b95c4953f8a3dc76fbc90cbcc3956505fc92d3eb33c1c90870fa4a9033e11 nototools-20171030.tar.gz
-e0d37ab7c2398695a00053c8c47346406d5cf8dda7ff3e24482d5318786794bb601fd2dd813437054b558d52df8934fc3050dc41a9ec9090a08835cabedaaa1c data_path.patch
-507b929b029aa63095fc157237c526a527f6e58a7ef3c8f93c9880a7559cd5cf2ec98051a4825803acdbc3c56c661100e247b0cdd49b861d11ca98aa5a1d7964 unichr.patch"
+sha512sums="a5ce2931e41ad980a25f2abb132439205799f4864b9140981af581932eb883b7c3a75e9e77ecf90c834298900f2dbeb3786b7e1b8b687b80b00c02a03c82fbb8 nototools-0_git20191015.tar.gz
+e0d37ab7c2398695a00053c8c47346406d5cf8dda7ff3e24482d5318786794bb601fd2dd813437054b558d52df8934fc3050dc41a9ec9090a08835cabedaaa1c data_path.patch"
diff --git a/testing/nototools/unichr.patch b/testing/nototools/unichr.patch
deleted file mode 100644
index 325e8aaf6e..0000000000
--- a/testing/nototools/unichr.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -upr a/nototools/unicode_data.py b/nototools/unicode_data.py
---- a/nototools/unicode_data.py 2016-07-18 23:42:00.000000000 +0200
-+++ b/nototools/unicode_data.py 2016-12-16 01:26:52.293428181 +0100
-@@ -33,7 +33,6 @@ from os import path
- import re
- import sys
-
--from fontTools.misc.py23 import unichr
- try:
- import unicodedata2 as unicodedata # Unicode 8 compliant native lib
- except ImportError: