aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ocaml-curses
diff options
context:
space:
mode:
authorFernando Casas Schössow <casasfernando@outlook.com>2019-02-06 21:31:38 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-03-05 12:50:51 +0000
commit3e3a8d58ec5f3aa30d1de0e97390ee1ff9a71583 (patch)
treeb38dc9e265b071916ada12f765348374f32e5391 /testing/ocaml-curses
parentfc424f9b0dbf3dfc99d55ed790a83f0894577aa8 (diff)
downloadaports-3e3a8d58ec5f3aa30d1de0e97390ee1ff9a71583.tar.bz2
aports-3e3a8d58ec5f3aa30d1de0e97390ee1ff9a71583.tar.xz
testing/ocaml-curses: new aport
https://www.nongnu.org/ocaml-tmk/ OCaml bindings for ncurses
Diffstat (limited to 'testing/ocaml-curses')
-rw-r--r--testing/ocaml-curses/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/testing/ocaml-curses/APKBUILD b/testing/ocaml-curses/APKBUILD
new file mode 100644
index 0000000000..256e80e972
--- /dev/null
+++ b/testing/ocaml-curses/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Fernando Casas Schossow <casasfernando@outlook.com>
+# Maintainer: Fernando Casas Schossow <casasfernando@outlook.com>
+pkgname=ocaml-curses
+pkgver=1.0.4
+pkgrel=0
+pkgdesc="OCaml bindings for ncurses"
+url="https://www.nongnu.org/ocaml-tmk/"
+arch="aarch64 ppc64le x86_64" # restricted by ocaml
+license="LGPL-2.1"
+makedepends="autoconf automake libtool ocaml ocaml-findlib-dev gawk ncurses-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://download.savannah.nongnu.org/releases/ocaml-tmk/ocaml-curses-1.0.4.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ cd "$builddir"
+ default_prepare
+ autoreconf
+}
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr
+ make all opt
+}
+
+check() {
+ cd "$builddir"
+ make test
+ make test.opt
+}
+
+package() {
+ cd "$builddir"
+ export DESTDIR="$pkgdir"
+ export OCAMLFIND_DESTDIR="$DESTDIR/usr/lib/ocaml"
+ mkdir -p "$OCAMLFIND_DESTDIR" "$OCAMLFIND_DESTDIR/stublibs"
+ ocamlfind install curses META *.cmi *.cmx *.cma *.cmxa *.a *.so *.mli
+ install -D -m644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
+
+sha512sums="a49838f1d32bf96fda6c612ac1b38316f61c49aa015e61e49681eacf863234f36ffe71d4305dd34f8e3b0a5dc6d9757919a107bcfdf46bd90df128e975560948 ocaml-curses-1.0.4.tar.gz"