aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ocaml-libvirt
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2019-03-05 12:58:18 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-03-05 12:59:08 +0000
commit536e567476292fdea18b862b2e4b7fddd26bd31e (patch)
treeefb9c16666d10c1bb9f50f50d7e006accf2b3ac8 /testing/ocaml-libvirt
parent13eb3c75a32d19722717a47b6b3f1a413ba7a51e (diff)
downloadaports-536e567476292fdea18b862b2e4b7fddd26bd31e.tar.bz2
aports-536e567476292fdea18b862b2e4b7fddd26bd31e.tar.xz
testing/ocaml-libvirt: attempt to fix build on aarch64 and ppc64le
Diffstat (limited to 'testing/ocaml-libvirt')
-rw-r--r--testing/ocaml-libvirt/APKBUILD13
1 files changed, 11 insertions, 2 deletions
diff --git a/testing/ocaml-libvirt/APKBUILD b/testing/ocaml-libvirt/APKBUILD
index a6658f1b73..43c4c177ee 100644
--- a/testing/ocaml-libvirt/APKBUILD
+++ b/testing/ocaml-libvirt/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Fernando Casas Schossow <casasfernando@outlook.com>
pkgname=ocaml-libvirt
pkgver=0.6.1.4
-pkgrel=0
+pkgrel=1
pkgdesc="OCaml binding for libvirt"
url="http://libvirt.org/ocaml/"
arch="aarch64 ppc64le x86_64" # restricted by ocaml
@@ -23,10 +23,19 @@ source="https://libvirt.org/sources/ocaml/$pkgname-$pkgver.tar.gz
builddir="$srcdir/$pkgname-$pkgver"
options="!check" # there is no test suite/unit tests
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
build() {
cd "$builddir"
export OCAMLPARAM="safe-string=0,_"
- ./configure --prefix=/usr
+ ./configure \
+ --host=$CHOST \
+ --build=$CBUILD \
+ --target=$CTARGET \
+ --prefix=/usr
make -C libvirt all
make opt
}