aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ocaml-migrate-parsetree
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-03-07 00:10:01 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-03-07 01:33:56 +0100
commit13402771c633461928ad20f859414e238084a904 (patch)
tree1ca4d742a675363151f914471b74aa076800c95d /testing/ocaml-migrate-parsetree
parent4817fb7db6a13561daef2b1fb0ea102919450fd9 (diff)
downloadaports-13402771c633461928ad20f859414e238084a904.tar.bz2
aports-13402771c633461928ad20f859414e238084a904.tar.xz
testing/ocaml-migrate-parsetree: move ocamlbuild plugin into subpkg
Diffstat (limited to 'testing/ocaml-migrate-parsetree')
-rw-r--r--testing/ocaml-migrate-parsetree/APKBUILD12
1 files changed, 10 insertions, 2 deletions
diff --git a/testing/ocaml-migrate-parsetree/APKBUILD b/testing/ocaml-migrate-parsetree/APKBUILD
index df11701f81..91979c702b 100644
--- a/testing/ocaml-migrate-parsetree/APKBUILD
+++ b/testing/ocaml-migrate-parsetree/APKBUILD
@@ -9,7 +9,7 @@ arch="all !x86 !armhf !s390x" # limited by ocaml
license="LGPL-2.1-only-WITH-linking-exception"
makedepends="dune ocaml ocamlbuild ocaml-findlib ocaml-result-dev opam"
options="textrels" # ppc64le (?!)
-subpackages="$pkgname-dev $pkgname-doc"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-ocamlbuild"
source="$pkgname-$pkgver.tar.gz::https://github.com/ocaml-ppx/$pkgname/archive/v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
@@ -49,10 +49,18 @@ package() {
rmdir usr/doc
}
+ocamlbuild() {
+ pkgdesc="$pkgdesc (ocamlbuild plugin)"
+ depends="$pkgname=$pkgver-r$pkgrel ocamlbuild"
+
+ mkdir -p "$subpkgdir"/usr/lib/ocaml
+ mv "$pkgdir"/usr/lib/ocaml/$pkgname-ocamlbuild "$subpkgdir"/usr/lib/ocaml/
+}
+
dev() {
default_dev
- depends="$pkgname=$pkgver-r$pkgrel"
+ depends="$pkgname=$pkgver-r$pkgrel $pkgname-ocamlbuild=$pkgver-r$pkgrel"
local sitelib="usr/lib/ocaml/$pkgname"
cd "$pkgdir"